Computer account creation failed - Big Sur 11.1 - M1 Macbook

New Contributor II

We just updated our testing M1 Macbooks to Big Sur 11.1 to see if the issue with reinstalling the OS from Recovery boot is fixed (it does appear so). However, we are experiencing an error when it comes to account creation in the initial setup process. The error is:

Computer account creation failed
Your computer account could not be created with the name and password specified. Please try again.

Trying to create the account again errors that the name is unavailable, so you have to choose a different account name. It will also fail on the second account. Powering the device off and back on will bring it to the login screen where it will list the accounts that you tried to create, but the passwords will not work.

It exhibits the same behavior with or without DEP provisioning. It does not exhibit the issue when restored via Apple Configurator 2.




This was also happening to me, I had to create a new Prestage, and for whatever reason that resolved it for me. Not sure if that will do it for you, but it for sure worked for me. I can now use both Intel and M1 Macs in that prestage. I honestly just thought I set the original Prestage up incorrectly or that it was somehow corrupted, and did not associate these two things, might be worth a shot. However like @Cayde-6 it was not just M1 devices having this issue in my env.

New Contributor

I'm stuck with Intune and seeing it with using just Intune. Doing the erase feature from resetpassword seems to fix the issue. I have also been disabling FileVault before doing the erase and install fresh OS.

New Contributor II


It finally happened on an Intel machine for us and completely bypassed the Account setup screen. We did create a new prestage and tried using that. It did seem to work but then unfortunately the inconsistency came back where it still isn't prompting for account setup a majority of the time.

I have a ticket with Jamf and was told

"One thing we could try is to just have the Account Settings payload configured.

It will require that another admin account is created during enrollment, but the "Local User Account Type" is the important part.

Select to either have the local user created as an Administrator or Standard account and this normally forces the Account Creation screen."

Not really looking into adding another account this way but curious if any one else has tried this

New Contributor II

@qward we've had this issue on big sur machines for a while now. We've been working with support.
its pretty intermittent, but affects about 50% of enrolling machines.
We've adjusted the prestage enrollment, removed the account settings, added back in, removed profiles, adjusted jamf settings, stopped check ins, removed all on enrollment policies. sometimes something we do helps some computers, but then others still are affected and it skips account setup.
Its suggested right now there might have been an undocumented big sur change. See if you can ask about the ticket under my name, as the support team have been working with us about a month or two trying various things, so might be able to throw some knowledge your way.


I have manage multiple environments and something I ran into was that if the battery is below 25% (I know that sounds insane) it was causing us issues as well, I only noticed it when we pulled some Macs that have been sitting a bit on a shelf. This was on intel machines both Catalina and Big Sur.

Catalina Machines would fail 99% of the time with the "Error Retrieving Activation Record” but the Big Sur Machines would bomb out during account creation, seemingly getting further than the Catalina machines. Just throwing that one out there as well in case it helps anyone.

Charged them up and they were all good. Had to wipe them of course.

New Contributor III

Does anyone have a reliable fix for this?

We are seeing the same - about 50/50 (sometimes less successful) Pre Stage enrollments - failing on the 'Creating Computer Account' bit. We need to use this screen as part of DEP because we have a user-targetted MDM profile (IKEv2 VPN) and so the account must be a 'managed account' (e.g. through DEP).