Computers changing host name en masse?

New Contributor II

Has anyone come across this before, or know what might cause this? I have Macs constantly changing their host names back to "localhost", even with a policy I have set up to change it back to what's in the JSS (9.6, and started happening prior to updating). I'll easily have 10+ that magically change their names in a single day.

I've since disabled the policy, and don't have any other policies enabled that have anything to do with the name, nor do I have any software installed that (I don't believe) have anything to do with changing its name.

Any ideas what might cause this? I'm stumped. Not sure if it's something that the JSS might cause, or if I should look elsewhere. I thought I would throw it out to you all.


Contributor II

Do you happen to have any Managed Preferences or Configuration Profiles configured? I ran into this when using a Configuration Profile. I believe it was back in the 9.2/9.3 version of the JSS (haven't tested it since).

In my case I could reproduce it if I had a Configuration Profile, using the Login Window option. In the Login Window, under the Options button there is a feature called "Set computer name to computer record name". When this option was checked I'd get machines resetting to "localhost".

New Contributor III

I had the exact problem with the Configuration Profile. Before I knew what was happening I had over 500 localhosts on my network. It turns out there is a known issue with that Config profile. My JAMF rep at the time said that JAMF had put in a ticket with Apple about the behavior of that profile setting having changed after an update from Apple. Looks like the bug has not been squished yet.

New Contributor II

@Brad_G @Vikse - Thanks for the replies. I do have a couple of configuration profiles enabled (to separate groups), with Login Window options set, but neither of them have the "Set computer name to computer record name" option checked. I disabled those profiles, and recreated the settings with MCX. Hopefully the problem will go away. Glad to know that I'm not the only one running into this.