Configuration Profile Network Mount works only on First Login

New Contributor

I have created a Configuration Profile for mac os x 10.7 to add a network mount under login items for a smb share that is on a windows 2003 server. The mac is bound to active directory and when the AD user logs in the share mounts but only one time, if the user log outs and then log backs in the share does not mount even though it shows the profile is present.

Any Ideas


Augusto Venegas '85
IT Administrator
Belen Jesuit Preparatory School
500 SW 127th Avenue
Miami, FL 33184
Tel. 786.621.4074
Cell. 786.295.1004
Please visit our website at


New Contributor III

It seems to be a bug in Lion. we setup a couple of users with a shared mount in there login items and it works fine when they login. but if they were to logout and back in it won't mount. So I did some testing and since I never logout of my machine I would have never notice this.

Anybody can replicate this just by login to an account and mount a shared using connect to server.
Logout out and back in and try to connect to the any share using connect to server and it will not let you.

This does not happen on 10.6 only 10.7

Maybe somebody here can report this bug to apple.

New Contributor

We are running into the same problem. If the config profile is computer level then it will execute properly on the first user login, but not sequential logins by the same user or other users. If applying this setting at the user level, which I would like to do in order to scope drive access by login and not machine, it results in a "unknown" startup item with an alert tag.

There is a user template work around at user template build level but it doesn't provide the scope flexibility of config profiles. We are currently working off 10.7.4 for our deployment environment. Tested the issue in 10.8 additionally with the same results, applications work fine. Reported issue to JAMF Support, will follow up if I find a resolution.

New Contributor

We too are running into this issue. I just tried to mount a share using computer level on OS X 10.7.4 and it worked once. Tried user level and it is unknown.

New Contributor III

I am deploying configuration profiles to a lab and need to auto-mount an SMB share based on username. I thought everything was working properly with the Computer level policy until I read this post and tried logging into the machine more than once. The second time the SMB share doesn't mount! It seems like following a reboot, or some given amount of time the the share will mount, but we need this to be consistant for the users. Any ideas?

Contributor III

Is it leaving the folder behind in /Volumes? I know I have to remove those for certain shares at logout with a script and policy.

New Contributor III


No I didn't see a folder for it in /Volumes. In an attempt to circumvent the issue I attempted to use the script, but am experiencing the same issue; it only works the first time. In the logs I do see: com.jamfsoftware.mapdrive."smbsharename.domain": Already loaded

Further down: com.jamfsoftware.mapdrive."smbsharename.domain": execution error type -36 has occured. (-36)

New Contributor

We experience exactly the same problem with 8.52 (production) and 8.62(dev box).

I we did not manage to replicate the issue in Profile Manager on 10.7 server which means its a JSS issue.

New Contributor

Did this ever get fixed? What did you guys end up using as a workaround?

I've been trying to use the script.

It's been failing with:
Script result: /private/tmp/ line 1: html: No such file or directory
/private/tmp/ line 2: syntax error near unexpected token `<'
/private/tmp/ line 2: `<head><title>403 Forbidden</title></head>

Fixed this, it was a script permissions issue I had to chmod it before I uploaded it. Still didn't get the script working tho. Tested mounting via Configuration Profiles on 10.8.2 and it seems to work...

New Contributor

This has been quite some but id find a work around for this.

I created a folder /.login (I did not want the students to see this folder)
and inside there I placed an AppleScript app that runs every .sh file in the /.login folder.

And created a policy that runs my applescript as a logon item for the user.

This has the benefit of any additional per user item that needs to run at login, can be added to a package to be deployed to /.login and will run on every login every time