Configuration profiles not installing on the target machine

New Contributor


I have created a configuration profile and scoped to my machine, but it never got installed. In the logs it is always saying "Pending...". Tried to install through self service but no luck, clicking on the install button in the self servince always getting the same message saying "Installing.." thats it, no progress. When I download the same and it is installing properly and appeared in the Profiles Pane of System Preferences.

Earlier configuration profiles installed and worked perfectly, these days problem started. I tried all the options. Can you guys please help on this?


New Contributor III

I've had this happen to me before. I did some research and found that sudo jamf removeMDMprofile command helped. Here's more info on the command. Please be aware that if you are using Wifi Config Profiles, you'll need to manually join wifi or connect to ethernet before you can issue the next command sudo jamf manage to install all your config profiles.

Contributor II

@dharmateja, did you ever get this to work? I'm having an identical issue with what you've described. @jriv , I tried your fix and that didn't work. I've tried to deploy this 3 computers - two Catalina computers and one highSierra. One of the Catalina computers worked fine.