Configurator 2 auto opening Photos

New Contributor

I know this isn't strictly Casper related, but I know there are probably a lot of us using Configurator alongside the Casper Suite to manage iOS devices.

Just started using Configurator 2 and was disappointed that Photos STILL auto opens every time it detects an iPad when it's plugged in to my Configurator station.

I gave some feedback to this effect on the Configurator feedback page on the Apple website

...and they actually replied back within 24 hours!

"With respect to Photos launching on device connections, we have indeed been working with the Photos team to change this default behaviour. Stay tuned. In the meantime, it is possible to disable this with a defaults write:

defaults -currentHost write disableHotPlug -bool YES

It was a refreshing change to not only get a real person responding, but for them to actually pass on some useful advice.

So if you have any feedback on Configurator 2, I urge you to let them know via the above link, as it would appear they are finally actively listening!!


New Contributor

Thanks! That was bugging me.

Contributor III

Thank you!

Legendary Contributor II

Its been possible to change that behavior for some time now with the option buried inside Image Capture, but the option only shows up when an iOS device is actually plugged in.

I agree its annoying to have Photos, and iPhoto before it, auto launch whenever an iOS device is plugged in. Really wish they would not make this the default setting. Maybe my wish will come true though.

New Contributor II

No if they could only get this kind to do the same thing with iTunes.

I know you can do it on a per device basis but no across the board method for when you are syncing 30 ipads.

New Contributor III



I have been trying to get this to deploy via policy, but I cannot seem to get it to work successfully. I've tried via script attachment in policy and also in the Files and Processes to Execute Command. Done both from automatic policy via trigger, and from Self Service with no change.

Wondering if I could get hint or two from the community.


Valued Contributor

Do you have to logout or restart in order for this to apply? I just ran the command and verified the PLIST was created with the desired key & value, but Photos is still launching. OS X 10.10.4


If you type the command directly into terminal it applies immediately. I've also tried to run without the -currentHost tag, but the command specifically applies to the current logged in user. I was thinking because of that property, the general SUDO root source from policies run via JAMF wouldn't work with just a 1 liner

Valued Contributor

Well @qhle373 if it's supposed to apply immediately, then it's not working for me ...

Going to ~/Library/Preferences I'm seeing 2 x PLISTS related to Image Capture - the one I just created, and another one

Running the command on the also does not stop Photos from opening ...