Could not mount distribution point

New Contributor II

Has anyone had this issue before where packages in self service keep failing to install due to not being able to mount the distribution point? I can manually mount the distribution points on the machines and get into the folders but it keeps failing when trying to do so via self service to install apps. Currently running the latest OS and Jamf Pro 10.2.1. I have tried changing the user account on the distribution point for read and write access and sometimes that works to fix this but sometimes it doesn't. The time is correct on both the client machines and the server that jamf is hosted on.


Contributor II

Are you dismounting after manually mounting the DP? Self-service or policies that requires the DP will fail to mount if you already have mounted.

Open terminal and type "cd /volumes" and then "ls -a" and see if you find the DP volume. If you do, run "umount /volume/VolumeName"

Contributor III

Same issue here using 10.4.1 JSS.
Performed the cd /volumes then ls -a and nothing is mounted... but yet I still receive the same error, "Could not mount distribution point".

been trying to diagnose this for three weeks now. I Am no closer now than I was three weeks ago. I can SMB into the server share, I cannot afp into the server share though. The distro point says afp after I changed it from smb because we cannot seem to get anything to work on this beast.

we need help and fast...


I am also at 10.4.1 and see the same error message in log files when I try to install printers and applications from the SMB share. I've spent two weeks on this issue with two support tickets with JAMF.

Esteemed Contributor II

Any reason not to use HTTP (with its resumable downloads, etc.) rather than SMB? #askingForAFriend


New Contributor

Has anyone found the fix for this? I currently having the same issue.

New Contributor

We too are seeing this issue with Self Service or pushed policies showing could not mount distribution point for our primary and failover servers. We do know that in these cases Macs have network connectivity since the same failed policies can execute scripts. Opened ticket with Jamf support months ago but never got clear answer.

New Contributor III

Got a few MacBooks doing this same thing. They are all on 10.13.6 and I'm running Jamf Pro 10.9.0. They can successfully run anything from Self Service that does not require the distribution point. If it does try to mount we get a failure to mount, fails over to the secondary and also fails to mount. Hundreds of other devices at the same site have no issue. Removing Jamf profiles and framework and reenrolling does nothing to resolve this. I'm going to trying reinstalling the OS after a drive wipe and see if that resolves it. I just don't know what else to do. Can also confirm that no other drives are mounted on the device.

New Contributor III

Same problem here. Sorry to bump an old post, but this is just annoying. Anyone have a fix yet? If I manually mount the share on my endpoint, I can use Remote to install anything I want. Easy enough for a machine or two, but not ideal...

Esteemed Contributor II

@jbanks You really want to enable HTTP/HTTPS content delivery for your distribution points. The install experience will be much better when you stop using SMB. I think Jamf is doing a huge disservice to its customers by not stressing this during a JumpStart.

New Contributor III

I switched over to AFP, but I still get the same error. I don't know what has changed, and honestly, can't tell you the last time I used remote (I had to rebuild my server, so it's been a bit).

New Contributor III

Here is my error log...

Log started 5/31/19 at 10:41:40 AM by administrator
Install VLC-3.0.3-072518.dmg
Selected Computers

ex-design-02 (329)

Sending Wake On LAN command...
Opening SSH Connection to
Successfully authenticated.
Verifying Computer's Identity...
The MAC Address has been verified.
Checking Operating System Version...
Running Mac OS X 10.14.5 (18F132)
Verifying /usr/local/jamf/bin/jamf...
/usr/local/jamf/bin/jamf is current (10.12.0-t1555503901)
Verifying /usr/sbin/jamf...
/usr/sbin/jamf does not exist.
Verifying /Library/Preferences/com.jamfsoftware.jamf.plist...
Preparing Policy...
Executing Policy 2019-05-31 at 10:41 AM | administrator | 1 Computer
Mounting CasperStorage
Could not mount distribution point "CasperStorage"
Submitting log to

Valued Contributor

Are you sure of the password Jamf Pro is using for the DP? Can you update the password in the field and then change the password for the user in on the actual server as well?

Valued Contributor

What happens if you do a sudo killall NetAuthSysAgent before attempting the installation?

Esteemed Contributor II

@jbanks By any chance do you have an ! in the password for your distribution point share? If yes there's an open PI for the bug I reported with that causing a problem mounting a share via the jamf client, so changing to a password without an ! should solve the problem.

New Contributor II

I was finally able to get our DP to mount by changing the Server info from the server name to the ip address.

  1. In JSS, go to Settings > Server Infrastructure > File Distribution Points and click the name of your distribution point.
  2. Under General, enter your server's IP Address in the Server field without the port number (e.g.
  3. Under File Sharing (we use SMB) make sure the Share Name is correct (e.g. CasperShare)
  4. Enter the server port number in the corresponding field (e.g. 8443).
    *Note: I left the workgroup field empty.

    That did the trick for us. Hope it helps you.

New Contributor III

My issue was that it would only happen to one or two computers after enrollment. So I ran "sudo profiles renew -type enrollment" and  "sudo jamf policy -enroll" and it has fixed the ones I have run across so far.