Creating OS X Mavericks NetBoot

New Contributor


I have been trying for weeks to create a Mavericks NetBoot image to run on my MacMini Server. Here at work we have a verity of Mac devices. Some are older and some are the current release models in stores. Prior to receiving the new (Late 2013) MBA models, we have never had an issue booting into the NetBoot which was created from Mountain Lion and using JSS to install our OS X image onto the device. Every time I try to NetBoot from the new Macs, I receive the "No Entry" logo on my Mac and then the device shuts down. I have been able to push a Mavericks image to one of the older Macs but still no luck connecting a newer Mac to the NetBoot even after creating a Mavericks NetBoot image. Would someone be able to point me in the right direction and help me get this up and running.

Mac Mini Server Specs:
[-] OS X 10.9.2
[-] OS X Server 3.1.1 (13S4140)
[-] CasperSuite 9.24
[-] MySQL 5.5.16

Sources I have used to try to resolve the issue:

Any help would be appreciated. This is driving me insane.




New Contributor III - Link was on the 9836 thread and fixed the issue you mentioned for me.

New Contributor

I gave that a try before with no luck. I ran the script and dropped my Mavericks NBI in there and let it ran. Afterwards, I tried the NBI Mavericks with no luck.

I just retried it again with the same results.


  1. Launched Terminal
  2. Typed

    sudo sh

    and dropped in the script

  3. Clicked Enter

  4. Typed in my Admin password
  5. Dropped my .nbi folder located in
    Server HD/Library/NetBoot/NetBootSP0
    in the Terminal window
  6. Click Enter
  7. When prompted after the script completes to make the .nbi larger than 10 gigs I click "N" and it says the script is complete
  8. I open up OS X Server and make the NBI I just dropped in the script the default and tried to boot from the never Late 2013 MBA with no luck

Valued Contributor

Are you saying that you are trying to build a 10.9 Netboot OS with a 10.8 machine? This wont work. You need to have a machine running the same version of OS as the netboot version you are trying to create. So to build a 10.9 image, you need to use a 10.9 machine. Once created, you can host it on an older netboot server.

Alternatively, are you saying that you are trying to use your original 10.8 netboot image on the newer machines to then deploy your 10.9 base image? Again, this also may not work. What OS is your netboot? The mid 2013 MBA shipped with a different build release of 10.8.4; build 12E3067, whilst most other machines were using build 12E55; late 2013 iMacs, 10.8.4, build 12E4022, so they wont boot if you have a 10.8.4 12E55 build netboot.

In theory, 10.8.5 should work, but only if Apple harmonised the differences between these builds. If this is the issue, it may be worth doing the above and creating a 10.9 Netboot image to deploy to these MBAs, but as said, make sure you match the OS versions between build machine and netboot version you're creating.

New Contributor


What I did was worked up one of the braned new MBA that we received with all the needing settings and JSS apps. From there I placed that laptop in Target Disk Mode and connected that device to Another MBA that is braned new. From there I used System Image Utility to create a NetBoot from the first MBA. Mavericks Device creating an NBI from another Mavericks device. I then uploaded the .nbi folder to my OS X server and tried to boot from one of the new MBA once I selected the NBI as the default on the server.

In my original post I was just trying to say that I am able to use my older NBI on my older devices showing that my server does indeed work. I'm just having issues with getting a Mavericks NBI working for the newer devices.

We recently updated the OS X Server App to 3.1.1 and the OS on the server to 10.9.2 as well thinking that was one of the reason why we could not get the newer MBIs working with the new MBAs.

Valued Contributor

One thing to consider, the NVRAM remembers a netboot set that has been selected in the past. If you don't clear this out, then the mac will continue to netboot from the original chosen one, not the default if you've changed it. You could clear this out (at chime hold [alt cmd P R]) or alternatively, boot holding down the alt key and you can pick which netboot you wish to boot from. I prefer the later as it makes sure you are picking the one that you want and doesn't clear other settings from the NVRAM.

New Contributor


So you are suggesting to clear the NVRAM on the macmini server after I change the default NetBoot image on the

Valued Contributor

Nope, the NVRAM on the client.

When you choose a netboot, the client remembers this choice, for example if you went into System Preferences and chose say a 10.8.5-Netboot, this is remembered. Every subsequent Netboot will now use that choice until cleared, regardless of you changing the default server side.

As mentioned though, if you hold 'alt' when you boot the client, then you can choose which netboot you wish to boot from, ensuring you are indeed using the correct netboot.

New Contributor

I am also having similar problems with a Mavericks netboot set.
We have a Mac mini running OSX server 10.8.5

Our default netboot is also 10.8.5 and it works with all our older devices.
However this set will obviously not boot up newer Retina devices that ship with Mavericks.

We created a 10.9 netboot set by booting into recovery mode on a brand new MBP (that shipped with Mavericks 10.9) and capturing a disk image, then booting back to OSX on the same device and running the disk image through System image utility to create the netboot - then uploaded it to the OSX server.
We made this the default and set it to be diskless boot, but when we try to Netboot (again on the same device) - it skips straight past and attempts to load HDD. Holding ALT has the same impact when we choose the 10.9 NBI, and we get the no entry sign when we try to use the 10.8.5 set. I have tried using target disk mode to create the netboot with the same results.
After trawling these forums and other internet posts I cannot determine why the 10.9 netboot is failing.
Our other older devices will not boot using the 10.9 netboot either, so its almost like the whole system image creation is failing to setup a valid netboot resource?

Clearing NVRAM also has had no effect :(
We were considering upgrading the server to 10.9 but from the O.P that looks to have no effect.

New Contributor II

Don't know if this is the same issue but we first started having this problem with new hardware a couple of years ago. We found the solution was to have a much more specific bless command for initiating netboot on the client. Not 100% sure why - best guess it's to do with the protocol forwarding on our network switches - but it works reliably for us.

Our script is below. You can also wrap it in an AppleScript app to make it easier to launch on demand.


#Variables for netbooting
server='<IP address of your server'
netbootSet='<File name of your NBI image including extension>'

#Set specific netboot server and netboot set as next boot volume and restart
bless --netboot --booter tftp://$server/NetBoot/NetBootSP0/$netbootSet/i386/booter --kernel tftp://$server/NetBoot/NetBootSP0/$netbootSet/i386/mach.macosx --kernelcache tftp://$server/NetBoot/NetBootSP0/$netbootSet/i386/x86_64/kernelcache --options "rp=nfs:$server:/private/tftpboot/NetBoot/NetBootSP0:$netbootSet/NetBoot.dmg"
shutdown -r now

Disappointingly, the Casper JSS *almost* lets you put all that extra detail in to create a Netboot Server. It's missing the last bit (after the --options switch) and without that it doesn't seem to work. We'll therefore stick with the script wrapped into an app and push that to where it's needed instead.