Default Dock policy for AD users

New Contributor III

Hey Guys,

Im setting up a policy to configure the default dock. I've tried the policy as once per computer, once per user, and ongoing.

The dock is modified for all local accounts, but when an AD user logs in, it just goes back to the apple defaults, not my custom one.

Any ideas?


Contributor III

The way we accomplish this is by setting up the defaults we want in a test profile and than capturing the ~/Library/Preferences/ with composer and use the FEU and FUT options so that the user template that new AD profiles are built from contains that dock instead of Apple's default.

Not applicable

You can also use dockutil once you have added a dock.plist into the User Template in /System/Library/User Template/(language)/Library/Preferences/ - make sure you're careful about the permissions assigned to anything you add into the UT.

You might also want to reference the thread here about dockfixup.

Dock items can also be managed with configuration profiles.

Release Candidate Programs Tester

@Krytos AD with local homes or network?

New Contributor III

@bentoms local homes/user profiles

Release Candidate Programs Tester

@Krytos then what both @jasonaswell & @pete_c suggested should work. :)

Can you give those a go &/or advise on what you're doing that's not working?

New Contributor III


Yeah I've read that creating a package with composer would work.

I'm not near a computer with casper admin tools, what are the FET and FEU options?

It just seems silly to have to create a package for it when theres options in casper policies to modify the dock. (I guess they just dont work as advertised.)

Contributor III

@Krytos FEU and FUT options will Fill Existing Users & Fill User Templates. This will update the dock for users that have already been created (prior to deploying the package) and will make any new users on that machine inherit the updated dock as part of the new user template.

New Contributor II

If I'm pushing out policies to update the dock. I find that I have to kill the process "cfsprefd" then kill dock.
However I still get an additional "Download" folder with no access, referring to an another admin account...
How to fix? LOL

Contributor II

@kevincnow Were you able to fix the issue with no access ? I am getting it for Docs and Downloads along with getting the additional Downloads folder as well.

It's weird because I haven't have this issue until now, I used to just delete the dockfixup plist and it would be fine.

All feedback is appreciated.