DEP Enrollment Problems

Not applicable


i am really new on work with jamf pro. I'm in the process to test the evaluation cloud for the company i work. I try since 4 weeks to enroll one MacBook Pro i bought from an authorized reseller.

The User Initiated Enrollment works flawless. When i try to enroll the mac with the DEP, i receive the pop up: "Unable to Configure Your Mac"

i tried this with the physical MacBook and with a virtual machine as well. Everytime i have the same error.
The Configuration in JAMF was controlled over a JAMF Sys Engineer and everything looks fine. We are now on the second eval cloud of the reason, then the jamf guy was thinking something went wrong with the database on the first cloud. But the behaviour is the same. I don't have created some special dep configuration. Only the needed steps to try the enrollment. We are really interested to go with jamf for our company, but to this moment now its a really pain with this easy steps they should work and they don't work.

I am grateful for any help I can get for. I have no idea what to do anymore.


New Contributor III

Is your network open as described here?

Not applicable

Hi peaudunk, thank you for your answer.
The Tests are done in a open network. Our requirement is connecting to the jamf cloud not from the company network

New Contributor III

What do you get from this:

Remove the test machine from the PreStage
Set it up manually
Scope it back to your PreStage
Run the following from Terminal:

sudo profiles renew -type enrollment

If it doesn't work you could look into MDM logging - though not sure if this all still works for 10.14+

Not applicable

Thank you very much, i will test it today