DEP iPad asking for credentials to install Apps.

New Contributor III

Hi, I have a DEP iPad that I am trying to deploy Apps to. The Apps are in the jamf Mobile Device Apps list. The It keeps requesting credentials as per the image. In the Management tab for the device, the app is shown as scheduled, but failled with "not available to install"
I have tried ticking and unticking "require iTunes password" and rebuilding the device with no effect.


Contributor II

The JSS probably tries to install the Self Service Mobile App from the App Store.

Go to Settings > Mobile Device Management > Self Service and change it to "Neither (manual installation)"


Release Candidate Programs Tester

Also make sure under the general tab for that app, you have the dropdown set to "Install Automatically/Prompt Users to Install."

Then also make sure on the VPP tab of that app, you have the box checked to assign VPP Content.

This will ensure the app gets installed without seeing that notification.6756b489de924793970cf40281f4e0b1


To re-emphasize what ChrisRupert said, you need to select the "Assign VPP Content" checkbox in order for the app to be assigned to a device (as opposed to a person via Apple ID).6ac84f842956450db8faef0c2d2635de

Valued Contributor

We're a bit back on our JSS version - 9.82. However, I see the same credential prompt on iPads that have been (undesirably) updated to iOS 10 from iOS 9.3.4 / 9.3.5 when we configured them this summer.

iPads still on the older iOS version do not cause this prompt to appear when distributing apps via VPP. I'm guessing our version of the JSS and the iPads being on iOS 10 is the issue for us.

Not sure if this is the case for you as well.

New Contributor III

I spoke to the Comp Now people and was advised to change the App site to None and instead set a Scope to a Department.

This has worked, but I have no idea why. it could be simply that the App data was refreshed, as the VPP numbers weren't appearing on the Mobile Device Apps listing and there was no content in the App VPP tab until I made the changes as posted by @ChrisRupert above to each App's settings.

Thanks for all the replies :)