DEP Setup is Being Skipped

New Contributor II

I have 400 devices that are being setup, (they have already been setup in DEP) - 98% of them go through the process as expected, and work great. However, a few of them are in DEP, are setup in Pre-Stage Enrollment, but continually skip over the DEP enrollment when they go through the setup screen (even after being reset a couple times). I have verified the settings many times, and all other devices worked fine. Has anyone seen this issue? Resolutions?



Valued Contributor II

Hey @brandtc][/url

Silly question, but it's the first thing that jumps to mind, and we might as well rule out the easiest cause first:

The iPads that are failing, which version of the iOS are they using?

If they're using anything not in the iOS 7 range, that would be why they're skipping it and failing; DEP enrollment requires iOS 7.x.x.

iOS 6 (or 5 or 4) devices will exhibit the exact behavior you've described.

Amanda Wulff JAMF Software Support

New Contributor II

Thanks Amanda, I appreciate the response. I have been working on the issue for a while today, and it appears that it can be resolved if you go to Mobile Devices > Pre-stage enrollment > Go to the enrollment profile > Find your device, disassociate it, save, then re-associate it. I have been able to resolve all devices through this method.

Valued Contributor II


Glad it's working! I wish I had a reason as to why you had to do that to get them to work; it's not something I've run into before. I did a quick search of past cases and open defects and didn't find anything similar either.

I chatted with your Technical Account Manager and she hasn't seen that before either. It's possible we just hit some kind of bizarre anomaly specific to the small handful of devices in question that is hopefully a one time thing that doesn't happen again.

If you do see that behavior return, however, please open up a case with your TAM and send over a copy of your JAMFSoftwareServer.log so we can see if there are any clues in there as to what might have happened.

Amanda Wulff
JAMF Software Support


@brandtc What you're doing is what we did to resolve that on a few of our devices.

We spoke to Apple about it, and they recommended to restore it and then go into JAMF and initiate some change so that the device profile could re-load. Really the only thing you can do is what you've done to disassociate and re-associate.

New Contributor II

Thanks @qhle373, glad to at least have it resolved.

New Contributor

We are also seeing the DEP setup skipped if the user recovers from an iCloud backup.

New Contributor

Thanks brantc! - worked for me too!

New Contributor III

Out of curiosity, was the backup created on that specific iPad prior to DEP enrollment? In our deployment, I noticed that under those conditions, DEP will be skipped and supervision dropped. If the backup is restored to a different iPad though, this isn't the case - DEP enrollment proceeds normally.