Device Compliance - Cannot register devices!

New Contributor III

We have tried to set up device compliance multiple times and it keeps failing on registration. 


I currently have a ticket open with jamf support but its going nowhere.

I have upgraded my cloud to version 10.46.1

Here is part of the log from the company portal app.

2023-05-25 13:37:31.279 | workplaceJoinSdk | 344229 | INFO: -[WPJBaseKeychainAccessor getRegistrationInformationWithTenantIdentifierInternal:domainName:error:] [Line 190][2023-05-25 13:37:31 +0000][WPJBaseKeychainAccessor] getRegistrationInformationWithTenantIdentifierInternal - check for incomplete registration or no registration.
2023-05-25 13:37:31.279 | workplaceJoinSdk | 344229 | ERROR: [errorCode:-400][2023-05-25 13:37:31 +0000][WPJBaseKeychainAccessor] getRegistrationInformationWithTenantIdentifierInternal - tenant is unregistered!
2023-05-25 13:37:31.280 | workplaceJoinSdk | 344229 | ERROR: [errorCode:-400][2023-05-25 13:37:31 +0000][WPJDecisionHandler] retrieveKeychainAccessorForTenantInternal - unable to retrieve valid registration information for the tenant. 


but we see it connected in both jamf device compliance and intune partner compliance mangement. 


is someone able to show me the permissions applied to both of these apps so that i can compare to ours?

User registration app for Device Compliance


Cloud Connector for Device Compliance


I have tried everything, sudo jamf manage prior to registration, i have applied the webkeyview config profile to eliminate the browser, The jamfAAD never pops up for us . just fails after inputting credentials. 


I would appreciate any and all assistance. tyvm!