Disable Mavericks Sign in with your Apple ID at login prompt?

New Contributor III

Hi everyone,

Has anyone worked out how to disable the "Sign in with your Apple ID" prompt at login?

I currently have the following keys set for the default template for new users:

OSVERS=$(sw_vers -productVersion)
OSBUILD=$(sw_vers -buildVersion)

com.apple.SetupAssistant "DidSeeCloudSetup" -bool true
com.apple.SetupAssistant "LastSeenCloudProductVersion" -string ${OSVERS}
com.apple.SetupAssistant "GestureMovieSeen" -string none
com.apple.SetupAssistant "LastPreLoginTasksPerformedVersion" -string ${OSVERS} com.apple.SetupAssistant "LastPreLoginTasksPerformedBuild" -string ${OSBUILD}

I use a function in my shell to write these keys which is why you don't see the full defaults write and path to file in the above keys that i use.

Are they any other keys that mavericks needs to suppress the Apple ID prompt on first login?




New Contributor II

Rich Trouton has a write-up on this, we were able to adapt his script to our environment fairly easily.


View solution in original post


New Contributor

Thanks for this updated script. I am planing on inplimenting this in my latest 10.12 upgrade.

Quick question, I have scripts that run before the OS upgrade, creates a LaunchAgent that's set to use the preloginwindow so I can run scripts post upgrade but before the user logs in.

The problem is the OS upgrade completes then sort of auto logs in but not really. After the OS Upgrade the user is presented with a login window with their username pre-filled. (Looks lie FileVault login for example.) the issue is that the LaunchAgent doesn't run.

If I touch .applesetupdone before the OS upgrade completes will this stop that prepop and allow my LaunchAgent to run?

Or any thoughts on how to get it to run? If the user logs in then immediately logs out, the LaunchAgent fires as intended. It's just a bad user experience to have them login then right back out.

New Contributor III

The ability to disable AppleID/iCloud sign-in has been added in configuration profile settings of JSS 9.93 and later.

New Contributor II

@Bobojo This behavior was removed in 10.12 (thankfully!) so you don't have to be concerned about it.

New Contributor III

@ jgalante

The ability to disable AppleID/iCloud sign-in has been added in configuration profile settings of JSS 9.93 and later. Does this still work for 10.12? If so, do you know the means/steps in config profile to accomplish this. I want the set up assistant to NOT show up on the admin or user side at first log in.

Thank you in advance for your help or response.

Contributor II

Has anyone got this working on Sierra, High Sierra and Mojave ?

I think it works on Sierra, but newer versions seem to ignore it

New Contributor II

I'd like to know if anyone else has gotten this working, too. It's killing me. It was working up until Mojave for me. I've tried everything I can think of at this point. Config profiles aren't working and the original suppression script isn't working anymore either.

New Contributor III

following ..

New Contributor II

Forgot I had this package in my repository. Added it to our base install policy and all is now right with the world.