downloading from CasperShare/Packages instead of CasperShare

New Contributor

We updated our servers to 10.10.4 and JSS to 9.73 and for the life of us, cant figure out how to solve this, finally turning the gurus of JAMF Nation

Let me start by saying we are new at JAMF, and sure we are making some small or easily fixable mistake, but think we tried as much as we can Google and JAMF Nation, and feel like we are at a point where we need help...

All our applications are stored within CasperShare/Packages, but for some reason when a policy is pushed, for example the 10.10.4 update policy, it reaches out to /CasperShare/ only and then comes back as file not found...

going to /CasperShare/Filename.dmg gives 404 error - /CasperShare/Packages/Filename.dmg downloads fine.

So I moved filename.dmg from /Packages/ to /CasperShare/ and bam! it worked!
Now we would move all our files out of Packages to CasperShare BUT in CasperAdmin, if we add FileName2.dmg, that automatically gets dropped into Packages folder by default.

So we thought why not create a symbolic link from Packages to CasperShare, but when we do that, we get a error message every time we launch CasperAdmin... it says Packages does not have correct permissions.

and thats where I have been banging my head for the last 2 days now!

Any help would be appreciated.



Valued Contributor

Just a quick question about the configuration of the distribution point.

In the JSS, in Computer Management > File Distribution Point > (YOUR DP).

What is the 'Context' of the share?



The context would be 'CasperShare'.

A screenshot of your setup with personal information scrubbed out would help!

New Contributor

So here is how its setup... and you are going to have to bear with me here, this is how it was setup when I got here, and thats what we are trying to figure out now :)

Since we have 3 distribution points...
Site1, Site2 and Site 3

Whats listed under File Distribution Points is:
Site1 CasperShare [afp]
Site2 CasperShare [afp]
Site3 CasperShare [afp]
Site3 CasperShare [smb]
DMZ External [SMB]
DMZ Internal [SMB]

the non-DMZ ones don't have context since HTTP is not enabled on them
the DMZ ones have HTTP Enabled and Context is set to CasperShare

I can do screenshots if needed, but not sure what you exactly you want screenshots off.


Valued Contributor

@mitulpatel2003 Does it also say "CasperShare" in the Share Name field in the File Sharing tab?

Contributor III

Here is a visual representation of the setting that should be verified:


What type of Web server are you using on your HTTP-enabled distribution points?
a. IIS (Windows)
b. Apache (Linux)
c. (Mac)

New Contributor

Sorry for the delay.
Yes, so the Share Name is CasperShare for all over the DPs listed.