Enrolling with Management Server Failed

New Contributor III

Hi Guys,

I am trying to workout ADE (First time) but i keep getting an error on my brand new Macbook Air M1 saying "Enrolling with Management Server Failed. The Server certificate chain for your organisation's MDM server was not properly set up." I have deleted the old ADE connection in JAMF and ABM, recreated a new one with the public key and token, however its still doing it. Any ideas ?

I have opened a support case however it looks like its just taking time, so thought maybe I'd ask you guys for some ideas while waiting.


New Contributor III

This post can be deleted or ignored. The issue was resolved after recovering and reinstalling macOS.

I just received same error. Can you post the fix?

I did a few things to resolve this issue: 

  • delete the Computer Record
  • Created a new PreStage and made sure there were no Certificate settings with Anchor Certificates
  • then on the Macbook Pro, I had to go to Disk Utility and erase the drive, and reinstall the macOS, not once but twice. (just restarted the MacBook Pro setup did not resolve the issue, had to wipe the Macintosh HD)

then it went through 

New Contributor II

We tried reinstalling macOS but still same issue.

Screenshot 2021-12-13 at 12.56.11 PM.png

New Contributor

I'm having this issue too.  I've reached out to Jamf support and even our account manager and no reply after a week!  I'd even appreciate a "this is a known issue, please refer to XYZ page" or anything at this point!  Even after restoring the OS, I still get this error.

New Contributor II

Getting this error on one of my 2014 MacBook Pro's.. Gonna need to call Jamf... I have not needed to re-set any other devices so I don't know if this is all of our devices or just this one. 

New Contributor

bumping this, was there a fix for this issue?

Yes, I just received same error. What is the fix?

New Contributor II

So I ran into this issue with a new Out of Box Macbook Pro2021 M1.  It was my 17th device enrolled since we started setting up JAMF less than a month ago.  Based on dmichels idea I ended up starting the system in recovery and erasing the OS Drive.  I then did a new Monterey install on the drive from recovery and after it came back it enrolled like normal.  I have no explanation yet but am glad this worked even if it wasted a bunch of time.