Enrollment post flight script failing

New Contributor

Hello all

I have a 2014 Macbook Air that I enrolled in Casper in April and it stopped checking in a couple days later. I tried running a few commands (sudo jamf recon and sudo jamf manage) and received errors that "jamf" was not recognized. I uninstalled the jamf framework via terminal /usr/sbin/jamf removeframework with the idea I would re-enroll it. Now when I re-enroll it via an enrollment package I created I'm getting an error that the post flight script failed to run. I checked Console and see an error stating the post flight script failed with "weird error 2". I tried enrolling it via an enrollment invitation, going to my jss/enroll and created a new enrollment package just because non of which were successful. My JSS is currently on v9.72 and I'm using the latest admin tool pack that corresponds to my JSS version.

Any thoughts on what to check next?

Thanks in advance!


Honored Contributor II
Honored Contributor II

I would make sure there aren't any configuration profiles left behind from previous enrolments (in System Preferences). Possibly also try deleting any records that are left in the JSS for that computer.