Erreur lors du déploiement du Self Service

Timone
New Contributor II

Bonjour,

Nous souhaitons déployer l'application "Self Service" sur nos tablettes, mais nous rencontrons une erreur lors de l'installation de celle-ci: "

L'identifiant ITunes Store de l'application n'a pu être validé

".

Pourtant, tous les ports réseau nécessaires au fonctionnement de Jamf sont bien ouverts ...
Jamf est en version v9.96 et nos tablettes sont en v9.3.5.

Avez-vous déjà rencontré ce problème?

Merci de votre aide,
Cordialement,
M. GAILLARD

1 ACCEPTED SOLUTION

Timone
New Contributor II

Bonjour,

Pour information, en passant par un relais 4G depuis un smartphone, tout se déploie comme par magie.
Ce problème est donc uniquement lié à l’existence de restrictions dans notre SSID ...

Merci de vos réponse, ce problème maintenant est résolu.

View solution in original post

12 REPLIES 12

TomK
New Contributor III

Bonjour,

Comment déployez vous l'application Self Service ? Le mieux est de déployer l'application en mode "Device" Voici un guide pas à pas sur le déploiement : https://jamfnation.jamfsoftware.com/article.html?id=370

Thomas.

arnaud_univlorr
New Contributor II

Bonjour,
Pas de soucis de notre côté.
Je joins les configs utilisés pour le déployer après l’avoir « acheté » via VPP, mais pas d’ »Assign VPP content » dans la partie VPP :

2bea4d29dfd64005a0574fbfb75c5c60
f35b7d975c9f4984b944ced906ade541

Avec pour les prefs :

<dict>
<key>INVITATION_STRING</key>
<string>$MOBILEDEVICEAPPINVITE</string>
<key>JSS_ID</key>
<string>$JSSID</string>
<key>SERIAL_NUMBER</key>
<string>$SERIALNUMBER</string>
<key>DEVICE_NAME</key>
<string>$DEVICENAME</string>
<key>MAC_ADDRESS</key>
<string>$MACADDRESS</string>
<key>UDID</key>
<string>$UDID</string> <key>JSS_URL</key> <string>https://serveurjss.domaine.fr:8443/</string>
</dict>

JAMF en 9.96 et iPads en 9.3.4

TomK
New Contributor III

Bonjour Arnaud.

Attention, tu as le Self Service mis à disposition dans le self service... 🙂

https://jamfnation.jamfsoftware.com/article.html?id=418

Thomas.

CSNavigateurs
New Contributor III

Voici notre setup de SS qui fonctionnant a merveille ... mon SS est acheter en VPP et distribuer a TOUTES les appareils mobiles

dans Reglages --- Gestion des appareils mobiles
4d2440a395b84dbbaf80205de82d43a5

a829bf1223de4ca4a1f3f53a326d4f1b

f53a333a8121408ead1fca28c6e668ec

tous mes apps Self Service mobile sont device assignable ...

Timone
New Contributor II

Bonjour à tous et merci de vos réponses,

Après avoir essayé de déployer une autre application de l'appstore, comme Chrome par exemple, nous nous sommes aperçu que nous rencontrions le même message d'erreur (validation impossible de l'ID de l'application).
Nous avons bien acheté suffisamment de licences avec notre compte VPP, et nous faisons de l'assignement device.

Nous devons sûrement avoir des restrictions dans notre SSID, nous empêchant de déployer des applications (depuis l'app store). Pourtant, nous avons ouvert, en sortie, tous les ports vers la classe 17.0.0.0/8 !

Avez-vous eu besoin, à l’université de Lorraine, d'ouvrir autre chose?

Merci de votre réponse,

Bonne journée,
Mickaël

arnaud_univlorr
New Contributor II

On a ouvert au niveau du serveur JSS, le web, le 443 et le 8443.
Au niveau du wifi, rien de spécial à ma connaissance en entrée. Tout est ouvert en sortie.

FredG
New Contributor

Bonjour, moi lorsque j'essaie de déployer Self Service en install manuelle, je n'arrive pas à accéder au contenu de l'appli (ecran gris avec message : impossible d'accéder au serveur) . J'ai pourtant ajouté et personalisé la petite partie dans "App Configuration" <dict>
<key>INVITATION_STRING</key>
<string>$MOBILEDEVICEAPPINVITE</string>
<key>JSS_ID</key>
<string>$JSSID</string>
<key>SERIAL_NUMBER</key>
<string>$SERIALNUMBER</string>
<key>DEVICE_NAME</key>
<string>$DEVICENAME</string>
<key>MAC_ADDRESS</key>
<string>$MACADDRESS</string>
<key>UDID</key>
<string>$UDID</string> <key>JSS_URL</key> <string>https://myaddress.blah:8443/</string>
</dict>

TomK
New Contributor III

Bonjour Frédéric.

J'imagine que tu as bien remplacé https://myaddress.blah:8443/ par l'adresse de ton serveur ?

Thomas.

multimedia06
New Contributor

Bonjour,

Vous dites avoir acheté l'application sur le vpp mais ne pas voir fait d'assign vpp... j'imagine donc que vous avez opté pour une distribution par appareil et donc bien coché la case "Attribuer le contenu VPP" dans la rubrique "Programme d'achats en volume VPP" au moment de la config de l'app...

arnaud_univlorr
New Contributor II

En fait, nous ne l'utilisons pas tellement pour les iPads, plus pour les Macs.
Nous avons "acheté" via VPP car le déploiement automatique ne marchait pas très bien mais le déploiement via VPP si. Au début, il demandait à ce que l'utilisateur se logue sur iTunes. Les iPads n'étant pas personnel, ça nous posait problème. Le VPP permettait de se passer de cette identification.
C'était il y a quelques mois maintenant. Maintenant, lorsque qu'un iPad est enrôlé, le self service se déploie sans pb.

FredG
New Contributor

@Thomas : oui bien sur, mais je n'y arrive toujours pas...du coup j'ai remis le Web Clip du SS et là ca fonctionne.

Sinon, suite à la migration en 9.96 et après avoir décoché "convertir en App gérée dès que possible" pour chaque App, cela fonctionne pour mon souci d'identifiant Itunes demandé suite à l'enrolement d'une tablette.

Timone
New Contributor II

Bonjour,

Pour information, en passant par un relais 4G depuis un smartphone, tout se déploie comme par magie.
Ce problème est donc uniquement lié à l’existence de restrictions dans notre SSID ...

Merci de vos réponse, ce problème maintenant est résolu.

View solution in original post