Error uploading iBook to Jamf Pro

New Contributor II

Hi All,

I have never done this before, but I am trying to upload an iBook that I download from the App store (free book).  Every time I attach the file to upload it to my cloud distribution point, it is complaining that I am uploading a file.  It is looking for just .ibooks, .epub, or .pdf.  Does anyone know a workaround to this?  Is this a way to convert ibooks to PDF?  I have looked around online but I do not see any tools that actually work.  Maybe this is a bug on JAMF's end?

Thank you


Contributor II

Have you tried more than one browser?

Yes.  I opened up a support ticket with JAMF,  they cannot do it on their end either.  Whenever you try to upload an ibook or an epub with the inhouse method, it seems like it cannot read the filetype.  Unless I am obtaining the ibook or epub files incorrectly (I am downloading them from the App Store and and uploading the whole ibooks or epub file).   I guess an ePub and iBooks file is technically a zip folder, and JAMF does not like it when uploading.  PDF is working fine for uploading.  

JAMF suggested doing it the other way, by assigning VPP licenses, and I have tried doing that but maybe I am setting that up incorrectly.  It seems a lot more complex to do rather than just uploading the eBook in-house and putting it in Self Service for users to download...

I got this resolved.  I had to enable a setting in my Volume Purchasing section of JAMF Global Settings.  After doing that and disabling the app store temporarily, the iBook finally got installed onto the iPad