Errors replicating to the distribution point

dlondon
Valued Contributor

Hi - beating my head on the wall with this.  Small files are replicating but this is a largish file of 8GB for Mathematica.  I consistently get this message when replicating to to the cloud DP of our Jamf Cloud server from our on prem SMB DP

Screen Shot 2022-01-14 at 5.04.52 pm.png
I've removed the DMG and re-uploaded it to our on premises SMB Distribution Point.

We've tested with our firewall and allowed all traffic in and out to my computer.  We also excluded the traffic from deep packet inspection.

I enabled the debug log on Jamf Admin and the end of log where the failure happens is:

 

2022-01-14 16:10:16: Copying Mathematica12.3_Lab.dmg...
2022-01-14 17:04:42: ERROR: copying  Mathematica12.3_Lab.dmg failed. Connection failure: "The operation couldn’t be completed. ( error 504.)"
Output: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>504 Gateway Timeout</title>
</head><body>
<h1>Gateway Timeout</h1>
<p>The gateway did not receive a timely response
from the upstream server or application.</p>
</body></html>

2022-01-14 17:04:42: Finished.
-- Unmounting   14/1/2022 5:04 pm --

 


I removed Mathematica from Jamf Admin and added a small DMG and that replicated fine.

This issue first cropped up when I was trying to update the Big Sur installer app which is in a DMG.  That's a 12GB file.  I thought I might have more luck with an 8GB file but no luck

Anyone else seeing this?  It's a while since I uploaded a large file as we are in the Southern Hemisphere - probably end of November


4 REPLIES 4

ponyboy
New Contributor III

I've been seeing this today and yesterday with the 2201 Citrix Workstation package. All I did was rename the officially provided .pkg file, but I keep getting 504 errors. I need to try other packages to see if this is a one-off, but I'd just replicated about 12-15 packages earlier in the day without any issues (ater downgrading Jamf Admin to 10.34.2 to workaround the PI with Jamf Admin 10.35.0).

bcbackes
Contributor II

I just ran into this same issue with trying to replicate Google Chrome. I get the same 504 Gateway Timeout error. The downside is my onprem DP isn't downloading the package when I set it up in a policy. The Jamf log shows: error says Package was not successfully downloaded 403. I have a ticket opened with Jamf on this. 

 

We haven't had any issues with this process for the last few months. I'm not sure what changed. I'm using Jamf Admin v10.31.

ponyboy
New Contributor III

I have a ticket open with this issue, it can be replicated, but they have not issued a PI.

Multiple packages provided by vendors are failing to upload via Jamf Admin (I was told to downgrade to 10.34.2, and I am now trying other older versions) to JCDS but will upload fine to JCDS with a curl-based script that accesses the API (this isn't useful to me in production, but allowed us to identify where the issue was occurring). I have a backlog of about 20 packages that I can't clear because I can't get them in both JCDS and our on-prem DP.

bcbackes
Contributor II

I ended up changing my workflow to get things to work. I change the primary DP to the Cloud DP, I then upload the package through Jamf Pro. Once that completes I go into Jamf Admin using the Cloud URL. I adjust the category as necessary if this wasn't done when uploading it. Then, I replicate it to the OnPrem DP. Once that is done I close Jamf Admin and reopen it to the OnPrem URL. I change the Category and whatever other settings I need and then save and close Jamf Admin. Lastly I go into Jamf Pro and change the DP back to the OnPrem DP.