Ethernet problems after upgrade to High Sierra

New Contributor

I upgraded the first of our iMacs to High Sierra on Friday. Unfortunately, the Ethernet is now having serious problems that weren't present before the upgrade. Running a ping test from one of my Linux servers to the Mac results in 25%-35% of the ICMP packets not getting a response. The network seems to be non-responsive for about 30 seconds, then responsive for about 90 seconds, then non-responsive for another 30 (it is not completely regular, but I hope you get the idea).

This reminded me of the Ethernet problem we had with Mavericks a while back, so I tried both a Thunderbolt to Ethernet adapter as well as a USB to Ethernet adapter. They both showed the same symptoms as the internal Ethernet.

Has anyone seen something similar?



Have you tried erase and install instead of updating ? Sounds silly but i think switching to new AFS has some issues try that first. test.

Contributor II

May sound even more dubious and could be a red herring - but check that the Ethernet lead is still plugged in correctly, and has not simply come loose.
- especially if it's missing a 'clip'… Always check the simple stuff first…

New Contributor

Did you get this figured out? Seems like I am getting the same issue on one machine. Wifi is fine though.