Final Draft 10 - Authorization and Update suppression

Contributor III

I'm sure the really smart people will be able to improve the steps I took to insert the Serial and prevent updates.

1: Download the newest version 10.3. Upload to the JSS
2: Install on your test machine. Authorize with your serial. This process will create the com.finaldraft.finaldraft. plist. I used Composer to capture the file.
3: I then created a policy with the installer, and the license package and the script below that runs after the install is complete


Define logged in user

user=ls -la /dev/console | cut -d " " -f 4

Run command with sudo as user

sudo -u $user defaults write /Users/$user/Library/Preferences/com.finaldraft.finaldraft.v10.plist IT-Install XFDY-XXXX-XXXX-XXX sudo -u $user defaults write /Users/$user/Library/Preferences/com.finaldraft.finaldraft.v10 SUEnableAutomaticChecks -bool no

When run for the first time the Authorization box pop up with the Serial pre populated. That's it



I know this is an old thread, and it's for FD10. But I figured if I post my solution here it might assist others, seeing as this post gave me the jump to get mine going.

I was doing this for FD11, but it should still work for 10 as that is when they built in autoscripted activations.

Final Draft (especially if you install manually at home) does go by system activation (all users). Do the following in a shell script and tell it to go to system library rather than user library preferences...

Set Serial Key

sudo defaults write /Library/Preferences/com.finaldraft.finaldraft.v11 IT-Install EFDY-XXX-XXX-XXX-XXX

Auto-Activate Final Draft Online

sudo defaults write /Library/Preferences/com.finaldraft.finaldraft.v11 IT-Install-NoPrompt -bool yes

Disable Auto Update Checking

sudo defaults write /Library/Preferences/com.finaldraft.finaldraft.v11 SUEnableAutomaticChecks -bool no

Ask to Register

sudo defaults write /Library/Preferences/com.finaldraft.finaldraft.v11 ShowRegister -bool no

This gives you, I think, one prompt when you first open the app to say "activated". But once that's done. It's over.

Thanks, just tried this for FD12, the above commands are all in a Post Install script in the .pkg, seemed to work OK in testing but the first user is getting an admin prompt.


Any ideas?

New Contributor

@summoner2100 That was really great info and super helpful. I am trying to get FD10 to perform a deactivate via script so that it can take the new license key. Looks like unless this is done manually it wont take the new license. Any suggestions?


@steve8141 Not as far as I know, FD10 had little to no automation ability. So it was hard. Suggestion would be to probably find where it's putting the license info, and see if a simple delete makes it trigger trialactivation.

Valued Contributor

Thanks for this! FD11 worked great with these instructions. FD's internal docs are terrible (they indicate you need to license per user, not per machine).

Thank you @summoner2100