HELP! Unable to disable audio "Thru" setting in Audio-MIDI Setup

1ManRockBand
New Contributor

The company I work for has rolled out Mac Minis as Zoom Rooms in several of our conference rooms. Some of those rooms have A/V racks that connect ceiling mounted microphones and speakers to the computer through an external audio card on the Mac (currently the external audio card is a crappy logitech headset adapter, but audio quality doesn't seem to be an issue).

The problem is, the mic and speakers feed back if the mic gain is turned up too high unless the "Thru" checkbox is unchecked in Audio-MIDI setup (which makes sense).

I can uncheck the box manually, but Audio-MIDI setup resets itself and re-checks the box after the computer reboots, which is scheduled once a week since the computer is a Zoom Room device.

I haven't been able to find anything (aside from Applescript UI scripting, which I would prefer to not use if possible) to un-check that box via a script.

The most promising thing I've found so far is:

/Library/Preferences/Audio/com.apple.audio.DeviceSettings.plist

This plist seems to be related to the values for the volume sliders of the connected audio devices shown in Audio MIDI Setup (see photos)
acac37fd33eb4d44ac178b9d585ef472

07b54720da0d4536b85933eef494efb6

Our Zoom Room Mac Mini deployment process is completely automated post-enrollment with scripts triggered by Jamf, and this is the last step.

I need to figure out how to make the un-checked "Thru" box keep its setting the same after a reboot instead of reverting.

Any help figuring this out would be greatly appreciated!

0 REPLIES 0