Help with hardware issue pci pause: SDXC

Contributor III

So hoping someone else has seen this issue not related to Casper.
We have a iMac Intel (27-inch, Late 2012) which hangs booting from the internal JHFS+ boot volume with there message pic pause: SDXC and then after a long wait gives "Still waiting for root device".
This machine will boot from recovery using r key and the diagnostics using d key. We have zeroed the disk, reinstalled OS using Install from external drive, and even was able to netinstall. Extended Hardware diagnostics shows no issues on multiple runs. Additionally when booting into Recovery the bless command:
bless --info /Volumes/Macintosh HD
returns and error like "Can't get information" (away from machine so I don't have exact error).
All this happens AFTER zeroing out the drive and doing a new install.
Google searches return some other reports of this pci pause: SDXC issue and the best I can tell it is a result of the EFI hierarchy failing to build apparently for the root device.
Also for the record, this is a 1T, spinning hard drive, that is NOT core storage, has never been encrypted and S.M.A.R.T. Status:Verified. And before anyone asks this had nothing to do with SD cards, there is no SD card in the slot and never has been.
Does anyone have any ideas?


Valued Contributor II

I'd say either bad SD Card slot or bad hard drive. Have you successfully installed a full OS (not recovery or diagnostic os) onto an external hard drive and booted from that? If that works, then replace the hard drive. If that fails, then replace the logic board. The Recovery or Diag drive may boot if it's not loading drivers for that bad SD slot so it doesn't hang trying to talk to it.


You also can run internet recovery on the computer. We had a similar problem like this and we ran internet recovery and it fixed it. I would also boot to an external os and run the AST Hard Drive test if that doesn't work.

Contributor III

@thoule Yes we have successfully installed a full OS. All the installs have successfully created a recovery partition.

@rhoward I will give the internet recovery a try since it is the one thing I have not yet done.

New Contributor

I've been having this same issue, but it's come up on an entire lab, with most of the computers having this problem. They were imaged and in place, then one by one, they would freeze up. On hard power down, they would get stuck booting at the pause that you have been experiencing. PRAM resets fixed them for a little while, but now they aren't booting at all.

They've all got spinning drives too. Been trying to figure it out for a while now.

New Contributor II

Just wanted to add:

Updated a lab full of recent model iMacs (HDs, no Fusion Drive) from 10.5.5 to 10.11.2 last week. Four days later I have 4 machines doing this.

Have tried all the basics: SMC, PRAM, ran Disk Warrior and Disk Utility, Safe/verbose mode, ran fsck, and internet Recovery. Never a hint of a HD issue.

These same machines were flawless from new until the 10.11 update. All have the same pci pause: SDXC comment in verbose mode.

Oddly, if when I try to boot them, the progress bar behaves normally to about 60%, and then takes about 10 min to get to 100%....but never actually completes.

After many attempts, a couple are now booting, but I can't say why. Seems random at this point. Feels like OS/software issue...

New Contributor II

Having read through this thread about the AD issue in early 10.10, my current issue feels/looks very similar. But as it is reported to have been patched/resolved with 10.10.3 or this the same thing again, or something else?

Three machines that eventually booted then suffered the same hang on the progress bar/Apple logo upon a proper reboot.

Update: After getting one of the machines to fully boot, I unbound it from AD. After still hangs the same way.

New Contributor II

For anybody following along, on a test box with this affliction, formatting and a clean install seems to have resolved it. Building a new image now, and have rebooted many time, and done about 6 hard shut downs. Also bound to AD.

Never a hang yet. No news is good news at this point.

Seems as though something was just not right with the OS upgrade from 10.5.5 to 10.11.2 on (at least part of) a lab. Driver, extension, start up item....dunno.

New Contributor II

Just adding this in case anybody else is digging around:

4 machines were wiped and re-imaged back to 11.10.2, then updated to 10.11.3 when it arrived. All were good for more than a week. Then they started hanging at boot again. At first one, then more machines, and them more frequently, until they were nearly always in a state of hung progress bar.

I have also noticed that they sometimes hang on student log out of an AD account, and then may reboot, followed by the long hang again. Could be an hour, or as much as 8 hours.

Finally threw in the towel, and re-imaged again back to 10.10.5. Have had reports from others on campus here fighting the 10.11 boot hang, so have pretty much ruled out my department's custom image, AD OU issues, or other possibly unique issues as a cause.

New Contributor

Booting into single user & running fsck seems to fix this. I'll update if it breaks again.

New Contributor II

Having the same issue with four Sep2013 21.5" iMacs with fusion drive.
Reinstalling them solves the problem for a while, but then it creeps back. They are part of a group of 16 identical Macs setup as surf-stations throughout the campus.
Sometimes, unplugging the mouse and then hard-resetting works. Sometimes a verbose-boot will "help". An fsck might help, but not consistently.
I've read elsewhere that "crippling" the fsck-binary has helped them (wtf?). I'll try that and classify it as a voodoo-measure.
Those machines have been at it for a long time. But they won't beat me!