How to package Symantec Endpoint Protection (SEP) 14

New Contributor


I just wanted to share with the community that I found a straightforward method to create a Symantec Endpoint Protection (SEP) v. 14 package. For me, it was hard to find an article with instructions to accomplish this. I could not find anything here and this is why I am posting this. I hope that it is helpful.
1. If you are managing your SEP clients via a SEPM, export the most recent Mac version.
2. On a test Mac, extract the Symantec Endpoint Protection Installer file.
3. Double-click Symantec Endpoint Protection Installer to launch the application.
4. Click Continue in the warning message to acknowledge that a system restart is required after install.
5. In the menu, click Tools > Create remote deployment package. Type the desired name, select a folder where you want to save the file, and then click Save.
6. When the package creation completes successfully, click OK. The .PKG file will be at the previously specified location.
7. At this point, proceed to upload the new package to JAMF and create a policy to deploy it.


Valued Contributor II

It's also important to note, that the installer itself doesn't allow you to quit without rebooting using the above method to create the installer package so you'll have to force quit or just install/reboot.

Valued Contributor

Anyone found a way to disable the quickmenu menubar icon? Doesn't look like it's possible in SEP14.

New Contributor II

To quit the installer after you've made your pckage, click agree an install then cancel the admin credential prompt.

New Contributor II

appreciate the write-up. I was not able to find any documentation on this as well until I stumble onto your post. Tried it and it works great.

New Contributor

I came upon the same steps when i was trying to figure this out myself. however when I upload my package to JamF Now Plus, it says the app is not signed with a certificate and will not let me publish it.

There is a step missing?

New Contributor II

Thank you so much for posting this! I was able to get it to install the apps but not the server connections. This did the trick!

Contributor III

To quit the installer application after creating your package just right-click the Dock icon and select Quit.

New Contributor III

These steps worked flawlessly on a machine that didn't have a previous version of SEP running. When I apply run this pkg against a machine with a prev SEP version, I ended up with 2 SEP clients. 1 pointing to the old Symantec server, the new client pointing to the new Symantec server. Anyone else encounter this? Is there a script for uninstalling previous versions that I could leverage?

New Contributor III

@RaymoJamf SymantecRemovalTool is a modification to RemoveSymantecMacFiles, designed to be pushed out using customer's choice of remote deployment tool. It requires no user input when run as root. As with RemoveSymantecMacFiles, all files and folders that Symantec Mac products have created will be removed; therefore, you will lose all files that reside in those folders, including any that you have created manually. For more information, please see the readme file included with the SymantecRemovalTool download. Symantec provides support for SymantecRemovalTool/RemoveSymantecMacFiles only when running them locally; it is the customer's responsibility to integrate SymantecRemovalTool with Apple Remote Desktop or other remote deployment tools.

Both of these tools requires no arguments. Any arguments they receive are each assumed to be potential installation points for Symantec products. Remote deployment solutions (Casper, JAMF, et al) that automatically populate shell script arguments ($1, $2, etc) with other data may cause the Symantec tool to throw an error. To work around this, the remote deployment solution may be configured to call first a dummy script that in turn calls the removal tool without any extra arguments.

New Contributor

A relevant update for anyone attempting this on a device running Catalina.

When using the Installer's Tools menu->Create remote deployment package:
"Remote deployment package creation closing ... Error creating package. Refer to console log for details."

Reset the extended attributes and permissions settings for the affected files. Open Terminal window and run the following commands:

sudo xattr -rc "/path/to/parentFolder/"

sudo chmod -R 755 "/path/to/parentFolder/"

e.g. for SEP installer files in user's Desktop folder "Symantec Endpoint Protection", /path/to/parentFolder/ would be "~/Desktop/Symantec Endpoint Protection/"

Then re-try the installer or tool.

New Contributor III

I can't get it to build the installer.
I am on 10.15.6
I have done xattr and chmod
I have added the Symantec Installer App to have full disk via privacy settings.
This is the logs:
2020-09-29 18:27:40.966 Symantec Endpoint Protection Installer[57166:3952103] Setup.ini file not found at path=/Library/Application Support/Symantec/SMC/setup.ini
2020-09-29 18:27:40.966 Symantec Endpoint Protection Installer[57166:3952103] SymantecRegistry.xml file not present. PreviousProductVersion not is not set
2020-09-29 18:27:40.966 Symantec Endpoint Protection Installer[57166:3952103] About to compare 10.12.0 with 10.15.6
2020-09-29 18:27:41.020 Symantec Endpoint Protection Installer[57166:3952103] * WARNING: Textured window <NSPanel: 0x7fb00d66e290> is getting an implicitly transparent titlebar. This will break when linking against newer SDKs. Use NSWindow's -titlebarAppearsTransparent=YES instead.
2020-09-29 18:27:41.023 Symantec Endpoint Protection Installer[57166:3952103] NSPanel does not support NSUnifiedTitleAndToolbarWindowMask in a utility window
2020-09-29 18:27:41.025 Symantec Endpoint Protection Installer[57166:3952103] NSPanel does not support NSUnifiedTitleAndToolbarWindowMask in a utility window
2020-09-29 18:27:49.891 Symantec Endpoint Protection Installer[57166:3952103] The package has failed validation and cannot be trusted
2020-09-29 18:27:49.891 Symantec Endpoint Protection Installer[57166:3952103] Package validation failed:-1
2020-09-29 18:27:54.963 Symantec Endpoint Protection Installer[57166:3952103] SEPremote done

Any ideas?


@llaneirer OMG, I see your post is two years old but I hope you're still around because I want to THANK YOU THANK YOU THANK YOU. I've been working on this package for weeks and was stuck trying to deploy a package that deployed a managed version of Symantec. It was driving me nuts. I tried your method and it worked right away. So beautiful in its simplicity. One more time: THANK YOU.