iMessage doesn't activate after iOS update.

brandon_ayers
New Contributor

Every time we update a device, once the device restarts, iMessage does not automatically activate causing everyone to use their apple ID instead of their mobile number.

I have to explain how to activate their iMessage in settings and I am not sure how to make iMessage automatically activate.

It will work if I manually go into settings and turn it off then back on.

3 REPLIES 3

t_santos
New Contributor II

I have encountered the same issue with my devices (iPhones) updating to iOs 14.3
Does anyone had found any solution ?

Thank you

Cayde-6
Valued Contributor

Ditto

willb
New Contributor

The issue seems to be related to the Pre-Stage setting to skip "iMessage and FaceTime" in Setup Assistant. When you first deploy an iPhone it skips the step and iMessage and FaceTime default to off. What is strange is that any time the device is updated, iMessage and FaceTime either turn off completely if the user isn't signed in with an Apple ID, or will deselect their phone number from the list of addresses and use their email as their caller/message ID.

Changing the settings in the Pre-Stages to show the iMessage and FaceTime step to the user "fixes" the issue for newly deployed devices. Then when they update the issue does not occur.

However, we've not yet found a way to fix this for devices that have already been deployed with the iMessage and FaceTime screen skipped. Every time they update, iMessage and FaceTime deactivates. This issue seems to have started with iOS 13 when Apple added the step to Setup Assistant to enable or disable iMessage and FaceTime.

It's also worth noting, that we've not seen this occur on iPads, only iPhones.