Infrastructure Manager upgrade not able to reach LDAP server

New Contributor III

Followed the process to update the Infrastructure Manager to V 2.2.1.
Uninstalled Java 8, stopped services, updated to Amazon Coretto 11.
Installed new Infrastructure Manager to V2.2.1. still unable to communicate with LDAP. Settings for LDAP worked this morning prior to update. This is a Windows 2012 server.
Error in Logs reads: closing connection b/c of SSL problem: Remote host terminated handshake.


New Contributor

Did you ever get your problem resolved?

New Contributor III

Still an issue - This has been marked as a bug but they still haven't worked out the exact cause or conditions for this issue as yet.

Esteemed Contributor

@MDMMan Do you have an SSL certificate for your LDAP server installed in the LDAP configuration on your JSS? The JSS apparently considers a certificate optional for SSL connections, and JIM 2.1.0 did not require one, but JIM 2.2.0 does.

New Contributor III

@sdagley We do have an SSL certificate in our LDAP config in our JSS. I suspect that it isn't actually using the cert we have installed.

New Contributor

Just checking, did you have any luck fixing this? Going through the motions for weeks with support around this currently.

Yes, I installed the previous version to get it working