Install Google Drive File Stream - System Extension Blocked

New Contributor III


Using the script below I can silently install Google Drive on the workstations. I just run into the following problem, and that a pop-up appears from System Extension Blocked, in which I have to approve Google.

Is there a way to forcefully approve this in the script?

Thanks in advance.

# Script to download, Silent Install and then clean up once installed Google DrivE FileStream

#Make temp folder for downloads.
mkdir "/tmp/filestream/";
cd "/tmp/filestream/";

#Download filestream.
curl -L -o /tmp/filestream/GoogleDriveFileStream.dmg "";

#Mount, Install, and unmount GoogleDriveFileStream.dmg
hdiutil mount GoogleDriveFileStream.dmg; 
sudo installer -pkg /Volumes/Install Google Drive File Stream/GoogleDriveFileStream.pkg -target "/Volumes/Macintosh HD"; 
hdiutil unmount /Volumes/Install Google Drive File Stream/;

#Tidy up
sudo rm -rf /tmp/filestream/

Trying your Missing F right now, crossing fingers

Even with that and a rebootScreen Shot 2021-09-08 at 4.13.10 PM.pngScreen Shot 2021-09-01 at 11.45.35 AM.pngScreen Shot 2021-09-08 at 4.14.37 PM.png, I am still seeing this:

With M1 and Big Sur


Screen Shot 2021-09-08 at 4.39.07 PM.png

Still Nada with Big Sur and Intel

Iam still trying also still havent found anything that is working


I got one to work with an intel computer with 10.15 on it with a kext. I noticed that there is a letter missing in the it should be  notice that there is a F missing from the first one.  Never got anything about allowing and never had to go security and privacy to do anythingScreen Shot 2021-09-08 at 3.22.50 PM.png

Thanks! Actually you are totally right this is missing.

Thank you for that trying now

Valued Contributor II

@Geissbuhler  those are the same popups i get when installing google drive for desktop. I have users install google drive via self service (using the pkg provided directly by the google drive download).

  I haven't applied any system extension config profile yet.  

Did you apply the system extension config profile before installing google drive?  

are you testing on both intel and m1 ?


For me on my M1 with Big Sur i didnt have any system extensions profile sent to the computer just installed it and then it launched.  On my Intel with 10.15 I put the profile on before i installed and there was no pop up.   I then installed drive before the profile was sent to the computer and had a pop up.  I quit Drive and then pushed the KEXT profile and relaunched drive and then I didnt get any pop ups.   I am getting ready to try it on a Intel with Big Sur.

Currently still at with the System Extension and PPPC config profile like above:

Big Sur on M1 = Works
Big Sur on Intel = Fails
Monterey Beta (21a5506j) on Intel = Works
Monterey Beta (21A5304g) on M1 = Works

Valued Contributor

Still having issues with this. Getting this pop up telling us we need to approve it in Security and Privacy area. 


When we go to Security and Privacy it isn't listed to allow. 

Odd thing is we just setup a new MAC before it got put into DEP and Google Drive worked fine. It stopped working as soon as we wiped it and put it through DEP and had Jamf manage it. I've gone through each Profile on jamf and removed them from the MAC one by one and the only ones that are left on there are the default ones that Jamf installs. 


Valued Contributor II

@Geissbuhler@konstantinb  hi - i'm going to try the following system extension config profile on Big Sur M1 @ Intel machines.  Let me know if any of it is extra stuff that i shouldn't need.

The third image is a little smaller because i wanted to include the whole 'system extensions' section in 1 screenshot.

Screen Shot 2021-09-16 at 9.52.01 AM.pngScreen Shot 2021-09-16 at 9.52.12 AM.pngScreen Shot 2021-09-16 at 9.53.05 AM.png

Contributor II

Having the same issue as the rest with intel macs on Big Sur, real head scratcher. Tried so many different settings in sysext but can't find a silent way to get this to work without a users manually accepting the new sysext and rebooting. 

Valued Contributor II

I manually accept the system extension but when i go to terminal and put in systemextensionsctl list

i do not see anything for google drive !!!!  does anyone else see this?

my system extension config profile doesn't work

Valued Contributor II

@Geissbuhler i'm testing with the PPC settings and the System Extensions settings - but only the 'allowed system extensions'  like you have in your images.

do you see the system extensions listed in your terminal when you put in the command systemextensionsctl list ???


Any update to this matter? Have a Intel MBP 11.6 where the user has nothing to approve in Sys Prefs...

Valued Contributor

Our issues was we had multiple PPPC profiles being installed. It seems like all the PPPC settings have to be in one profile so if you have multiple bits of software that require PPPC settings then put them all into one profile. This seemed to fix it for us.


I was able to fix it by deploying the Kernel Extension as follows:




Sort of off topic/on topic, I made a thread for this but probably more useful posting it here.

I am trying to push Google Drive from Jamf using the scripts provided here, however when it asks for permissions (I am not at the point of making PPPC or system/kernal extensions), but when this pop up comes up:

"To approve, open System Preferences > Security & Privacy. Click the lock to make changes, and enter your administrator ID and password. Under the “General” tab, you’ll see that some system software requires your attention before it can be used. After you give approval, restart your computer."

There is no "allow" and Google Drive does not appear in the General tab where you would generally allow this.  Has this happened to anyone/have any tips on how to resolve this?

We have seen this and the only fix for us was to deploy the kernel extension per my screenshot above. Since Google Drive is widely used in our Org - it was necessary to deploy it to all Macs.

You could try resetting all your kext approvals in Recovery via Terminal and:
kmutil trigger-panic-medic -R “/Volumes/Macintosh HD”

All previously installed kexts will prompt the user to re-approve them when they are loaded or installed.

I missed your response above with the config file, it would perfectly.  Thanks you for sharing.

Valued Contributor II

@kevin_v  @jlombardo  did you apply that Kernel Extension to Big Sur running macs?  did Google Drive prompt the user afterwards when they installed Google Drive for desktop?

I have Google Drive for Desktop in Self Service and whenever a BigSur user installs it there are all sorts of popups and even a restart prompt.

I have that kernel extension for Catalina

Sorry haven't heard of any additional pop-ups with the above CP in place

Valued Contributor II

@kevin_v  so you have that exact same configuration profile running on a BigSur intel Mac and it works?

I get nothing but system popups after installing google drive and then signing into my google drive account.

Once I sign into the google drive account then all the system popups to verify google drive was downloaded from google, then to approve the system extension and then restart.


so in total there is like 3 things that a user would have to do

1 - approve it was downloaded from google

2 - approve extension

3- restart

New Contributor III

Fun fact, if you mess up your hosts file, Google Drive will fail to load on an M1 Mac (macOS 12.2) and complain about the system extension, despite having a PPPC profile.


I had to regenerate the " localhost" definition before Google Drive would load off-campus (for some reason it would load fine on the campus network but not offsite).

Just leaving this here in case it helps another user or frustrated googler.