iOS System Apps not installing by default

New Contributor III

We've just started running into an issue where the system apps that are removable on iPads such as Notes, Maps etc will not install on their own after setting up an iPad.

We have been able to successfully navigate around it by excluding the student from the config profile we use to restrict App Store usage, but in the past they've just been there and it hasn't been an issue. Is this a recent iOS update issue where they are no longer installed by default? If so, it seems odd that they would be trying to install at all if the app store restriction is whats stopping them at 'installing'.


Valued Contributor

They are still free, but you will need a license (also free) to install them again. This happens after the first time you wipe an ipad (and everytime there after).

TLDR: Get licenses

New Contributor

Im getting the same issue, the apps show on the home screen but display the error unable to Install when trying to use them
The apps being mentioned, Notes and Maps do not show up in VPP to purchase licenses.

New Contributor

Having same issue in our teacher devices. There is no configuration profile on our teacher iPads. Try to add these apps from self service but couldn't achieve either. What am i doing wrong?


New Contributor

Same issue here, they are not available as VPP,

Valued Contributor

@pirireis Are you doing a restore from iCloud?

New Contributor

Good afternoon. Hoping someone resolved this error as it has occurred with an iPad this week. Wiped and set-up via Jamf Pro without issue, but - exactly as @piriries demonstrated - the device appears to require apps to be restored from iCloud. I have never encountered this issue before and have wiped 100s of iPads via Jamf over the years. Any help much appreciated, thank you.

New Contributor III

We are starting to run into this issue on many iPads. The only solution we have had so far is to do the "Reset All Settings" option in Settings>General>Reset. That seems to fix the problems with those apps. However, if anyone has a better solution I would love to know it.

New Contributor

We are also having the same issue. The files look like the screenshot from pirireis. I tried the "Reset All Settings" and that did not work.

New Contributor

Any one find a solution for this? I have the same issue with multiple iPads. When I prepare an iPad in Apple Configurator, I am missing system apps like Notes, FaceTime, etc. Big one for us is the Notes app, which isn't available in VPP.

New Contributor II

Seriously, a year later and no one has answered this? I'm having this problem and am searching for an answer and no one answered this?

I know it's not an ideal solution, but I did post above that doing a reset all settings seems to fix the majority of the ones we have issues with.  You don't have to reset the entire iPad, just settings.  That's the only thing we've found that works and are still not sure why it happens randomly.

New Contributor II

I just had this issue as well.  I am not sure if it was an iCloud login that caused the issue or not (Device wasn't returned at the beginning of the school year so who knows what the student did with it over that time), but wiping the device didn't work and the Reset all settings also didn't fix it for me.  We use the Notes / Files app and need that, but not sure what to do besides logging into a not student apple ID since we are a school and don't allow purchases....Seems like there should be some easier way!  Hopefully 2022 will bring a fix!

New Contributor

We had this issue as well and thought it was a network issue or cache setting issue because we were able to get the native apps when connected to a hotspot or outside network but couldn't get them when connected to our in-house network. We finally got it to work by going to Settings>Server>Software update servers and then unchecking the check mark for "Set system wide" in jamf pro.

I'm not even entirely sure how this fixed the issue but it did. My guess is it was preventing our devices from going out to Apple's cloud to retrieve the native apps and was relying solely on our caching server which doesn't cache the unmanaged native apps. If you have a cache server set up then I would try connecting a hotspot or outside network and seeing if the apps are able to get through and if they are then you are probably having the same issue we did.