IOS update 14.3 on ipads...

denice_clapper
Contributor

I work for a school and we recently had the 14.3 update, some of the apps have disappeared off the ipad screen, when you go to self service it says reinstall on the app but it wont reinstall, it will however let me install new apps...I have had several people with the same issue..anyone know why???

11 REPLIES 11

denice_clapper
Contributor

mostly microsoft apps that wont reinstall??

mainelysteve
Valued Contributor

@denice.clapper Do those missing apps show up in an inventory report or perhaps do they show as being removed under History > Management History? This is assuming you're running Jamf Pro.

denice_clapper
Contributor

Yes they show up as being there

mainelysteve
Valued Contributor

If they're showing up in an inventory report as being installed then perhaps check Settings > iPad Storage and see if they show up in that list. If so tap on the entry and choose Delete App.

denice_clapper
Contributor

@mainelysteve No not there...its strange ..sometimes it appears to be loading and all of sudden it disappears. and like I said it is several ipads

robii
New Contributor III

Do you have a Restriction in a profile that blacklists those apps? Maybe one that gets installed only when 14.3 triggers it? The behavior sounds exactly like what we do to whitelist apps. We have a list of "School Approved" apps that are allowed in a profile. All other apps are not allowed. If a student is in danger of failing we install that profile and all "non-school" apps disappear until they bring up their grades. Apps just disappear off the screen but are still installed and show up in the inventory. They show in Self Service with the Re-Install button. As they reinstall you see them on the screen as they install but immediately disappear once installed.

mainelysteve
Valued Contributor

@denice.clapper I concur with @robii. If they show up on the springboard(home screen) as installing then disappear you have a restriction set that is hiding those apps. You can verify that if there are no failed commands for that particular app when the reinstall button is pressed in Self Service.

denice_clapper
Contributor

Self service says reinstall on the apps, when you hit reinstall it says that it is already installed but it is no where on the homescreen, there are no restrictions blocking those apps, they are microsoft apps,

mainelysteve
Valued Contributor

Does it have an Apple ID signed into it? If so check that the offload unused apps setting isn't turned on. Also try resetting the home screen layout under General > Reset

denice_clapper
Contributor

Tried that @mainelysteve no luck! This is very frustrating, it only happened with the microsoft apps.

mainelysteve
Valued Contributor

It is really odd that it's cherry picking Microsoft apps. Do you have one you can wipe and setup again for giggles?