iPad IP displays load balancer IP - On-Prem setup


Anyone pros with maintaining self-hosted clustered Ubuntu Jamf-Pro instance?


After upgrading all of our Jamf-Pro hardware and updating to 10.48.2, our iPads only report the IP address of our load balancer to the JAMF pro GUI. We are running an HA Proxy load Balancer in front of all of our JAMF child nodes that is also used to terminate the SSL connection. We didn't really make any changes to our HA proxy configuration, but now the iPads that are on our internal network only display the IP adress. If an iPad checks in outside of the network it does get that public of wherever it is, but not on our internal network.


I messed with adding the "forwardfor" line in the HAproxy config and it doesn't seem to make a difference. Has anyone had this issue? 


Valued Contributor

its been a while and this may not be it.. but anyway.. https://learn.jamf.com/bundle/jamf-pro-install-guide-linux-current/page/Configuring_Tomcat_to_Work_w...

and this.. F5.. but maybe this will help: 

It’s something called X-Forwarded-For. When the F5 talks to the server, it still uses it’s own IP to communicate with it, but it lets the server know that it is forwarding it on behalf of a client at the forwarded IP. Both the F5 and the server need to be configured to use X-Forwarded-For. On the F5, it’s a setting that I had to enable for the jss http profile.