iPadOS: Awaiting final configuration from loop

New Contributor

Our organization recently moved over to Jamf Cloud from on-prem hosting. Trying to provision five iPads for a department. Stuck on awaiting final configuration from "our organization" loop. Has anyone experienced this before and if so how did you resolve it? I've already unassigned and reassigned the devices to our MDM in ASM and then wiped the devices in Apple Configurator. Left the iPads running overnight and it was still stuck on awaiting final configuration from "our organization". We had no issues with mobile devices with on-prem hosting.



By Chance did anyone receive a functional fix?  I still see this pop up, such as today where i cycled through 10 devices repeatedly until one decided to complete. 

New Contributor II

Our situation was caused by a certificate trust not being set for a WPA2 Enterprise Wi-Fi (PEAP)


Had this problem today. I had an ipad that was not in DEP. I added it using apple configurator method, and then assigned to jss. Now comes up with "managed by MYSITE" but cant proceed through the above error. Whiped the ipad many times, removed from jamf completely.... Since it is just inducted into apple school manager i didnt remove it from there. Dont have any timezone set.

I did have set "assign profile before setup assistant" on the prestage "newly assigned devices" and unchecked it. The ipad now works. But we have literally had that set forever with no issue. Would appreciate a better explanation of why this was necessary from JAMF if they are monitoring these forums.

EDIT: spoke too soon. Gets by that error but then never downloads policy. Update inventory command just hangs. tried hotspot as well to rule out network issues. sigh...

EDIT2: the root cause of this issue was that our push certificate expired (LOL) so check the obvious things first!!! lesson learned. I have restored the "assign profile" setting, as i thought that might not be the issue...  The ipad is now recieving settings and policy. 

New Contributor

Good morning,
In case you are using JAMFSchool, I was getting this issue with 14.X and 15.X devices. If you log on to the admin console, go to devices --> Inventory. Find the device you are having the issue with and select it. On right, under device details, click on refresh. That worked for me getting past the configuration loop. 


I wish I had more to add to this discussion but I wanted to leave a note here for others like me finding this in the future. We did not have install profiles before setup assistant enabled but we did have the set time zone setting enabled. After unchecking the time zone settings it appears to be working as intended. Our iPads are currently on iOS 16.5 so it doesn't appear to have been fixed on JAMF or Apple's ends.