iPads Not Communicating with Jamf

rharms
New Contributor

We recently enrolled our first hundred iPads through DEP. We weren't quite ready to deploy at that time, so they have been sitting a while.

Now that we are trying to deploy them, we find that we have quite a few that haven't updated their inventory in Jamf since the date they were enrolled. When we dig into the management history on the device, it shows multiple push commands that have been Pending since the initial enrollment. So, apparently enrollment didn't work as it should have.

Question is, is there anything that can be done short of factory restore and re-enroll. I've got about 55 of them with this issue, so would rather not go that route.

I tried re-enrolling by going to <JSS URL>:8443/enroll, but it always errors out.

Any advice welcome.

Thanks,
Ross

3 REPLIES 3

Ryan_
New Contributor II

@rharms What does it error out with during the user-initiated enrollment?

Also, are these devices connected to the internet presently? If they were enrolled and then turned off they will need to be unlocked again to connect to the internet and update inventory/receive commands from Jamf Pro.

Please feel free to visit the support section above and create a support case to have someone look into this further if needed.

Happy Wednesday!

jesperadmin
New Contributor

If iPads don't check in with Jamf (DEP). Can you make the connect by using manual enrollment invitation?

hedenstam
New Contributor III

I have also multiple iPads with pending commands. Something is off here.