Issues with Arctic Wolf Install

New Contributor II

So I created a policy for Arctic Wolf like i would for another piece of software.  When I tried installing it, I got the error in the attached screenshot.  Anyone else get this error?


Screen Shot 2022-02-01 at 16.30.24.png


New Contributor III
New Contributor III

Did you follow these instructions?

Also, are you installing on an Apple Silicon machine? If so, make sure you install Rosetta 2 before installing Arctic Wolf. 

Thanks for this!  Working on that now.  I have already installed Rosetta 2

So i completed the steps from the Arctic Wolf site.  I'm getting the following error when it's trying to run the execute command.



Screen Shot 2022-02-03 at 10.50.02.png


hmm permission denied?

the jamf binary runs as root... is the executable? 

make sure you

chmod a+x /path/to/

before trying to have jamf run the script

New Contributor

I'm also experiencing the same error.  Is there a solution?


New Contributor II

I'm having the same issue as well, anyone else find the fix?

New Contributor II

Hi all - running into the same issues here attempting to deploy Arctic Wolf agent via Jamf Pro on Jamf Cloud instance.

I can get the policy to run via self service on a iMac M1 and show a "done", but behind the scenes, the execute command provided by A.W. can't find the script.

Following step by step of Arctic Wolf instructions, and actually renamed the pkg they provided since it had a different name from the script they provide (it had a date and was all lower case)


Screen Shot 2022-04-20 at 9.26.40 AM.png


Shell script:

sudo installer -pkg /private/tmp/AGENT/ArcticWolfAgent.pkg -target /
exit 0
Jamf composer package:
Screen Shot 2022-04-20 at 9.33.26 AM.png

New Contributor

I was able to successfully package and deploy this! Reach if you need assistance. This has been a thorne!

New Contributor III

Hello There, 

Reaching out for some assistance I continue to recieve No Such File or Directory when it tries to run the script I have an M1 computer if it means anything. Thanks in advance 


I was getting the "No such file or directory" error and noticed that the agent was not in the /private/tmp/AGENT/ArcticWolfAgent.pkg path. It was in the /private/AGENT/ArcticWolfAgent.pkg so I removed tmp from the script, and it worked.

New Contributor II

Hello!  Looking for some help.  I am also getting "No such file or directory" error.  The "" is missing from the composer package.  However when I try to drop the file into the package it gives me an error message.  "Failed to copy file /usr/bin/ditto -rsrcFork /Users/atvenu/Downloads/arcticwolfagent/ /Library/Application Support/JAMF/Composer/Sources/Artic Wolf/ROOT/Library/ArcticWolfNetworks/Agent/ from /Users/atvenu/Downloads/arcticwolfagent/ to /Library/Application Support/JAMF/Composer/Sources/Artic Wolf/ROOT/Library/ArcticWolfNetworks/Agent/ [Command failed with error code (1): '/usr/bin/ditto']". Thank you