Issues with upgrading from Mountain Lion 10.8.2 to 10.8.3

New Contributor

Has anyone else experienced issues upgrading to OSX 10.8.3 with multiple user accounts? It seems that our testing leaves the account that performs the upgrade fine on a given system, but all other previous client accounts reveal a plain grey screen with cursor after login - Dock and Finder never launch. We are looking at the user templates, but it's not clear why this is happening. Any ideas would be great!


New Contributor III

Can you provide some more details; How you created the image... By multiple user accounts I assume Local? Have you tried resetting nvram to get them going? Command-Option-P-R.

New Contributor

we have seen a similar issue - at first I thought the update had deleted our casper management user but after some playing around I discovered it was just the password that was not functioning. resetting the password from single user mode, or via the accounts tab in a policy got the account working again.

Esteemed Contributor III

Combo updater?


New Contributor II

This is actually happening using the combo updater. We have our standard image that we have been using right along- everything seems to work.
But after the combo update the only account that works is the account it was installed with- this includes new Active Directory users.
If anyone else loggs in, AD users or local accounts, all that happens is a grey screen with a mouse cursor. From what i can tell everything underneath is still working such as policies and services. Packages can be pushed and applications can be run. But there is no user interface, no desktop, and no dock. This is consistent weather I push the update from Casper or use Apple Software update manually.

New Contributor II

What have people been doing to fix this?


I am having a different issue after upgrading to 10.8.3:

My machine is bound to an AD domain and now every time I open an Apple App such as the App store I get a popup that says:

"Mac OS X needs to repair your Library to run applications. Type your password to allow this."

The only fix I have found is to delete the mobile account and start again - even deleting the ~/Library file doesn't fix it. Has anyone else seen this?

Contributor III

I'd think it meant /Library, not ~/Library. I wonder if it's permissions related. Have you tried just repairing permissions?

EDIT: But removing the mobile account fixes it, so no, probably not /Library. So, I guess, ignore me.


Permissions repair doesn't fix the problem either.