Jamf 10.12.0 - Inventory Preload doesn´t work

New Contributor II

Hey guys,

we are running a jamf multi context environment.
Our production contexts are on 10.10.1 and inventory preload works great.
Yesterday we upgraded our test context to 10.12.0 and inventory preload doesn´t work.
Error message is "file extension not allowed".

The same preload csv file works in 10.10.1 without any problems.

Is this a bug in 10.12.0?


New Contributor III

I believe they changed a couple of columns since 10.10.1 you may need to download the new template and repopulate your data. Hope that helps.

New Contributor III

Tried it today on JAMF 10.12 and it works as expected. As suggested above, download the template and see if there’s any changes.

New Contributor III

@f.matheI faced the same issue and as per Jamf support, If you are using Windows edit the template and save in Mac csv format or you can edit the template the in a Mac and save it in csv then try to upload, it should work.
Or I love to do it using the uapi(Swagger UI):
1. Open the csv file you have in Notepad. CTRL+A to select all the text and copy it to clipboard.
2. Head over to https://jamfOrgUrl/uapi/doc and authenticate to generate a token.[use your jss credential]
3. Expand the inventory-preload >> POST /inventory-preload
4. Change the Parameter content type dropdown to text/csv. Note: this is not the Response content type which is irrelevant here.
5. Paste the text from Notepad into the Value field for the body and hit "Try it out!"

You should get a 201 response and the inventory preload data should be available in Jamf Pro for viewing.

New Contributor III

Running into the same issue. Tried the Mac format but nothing is working. Any new suggestions? We are on 10.13.0.

New Contributor

Same! Doesn't work for me. Tried to save from Excel into CSV (Mac) without any luck.
This used to work great.

New Contributor

Confirmed it working in 10.14.0!

Contributor II

Thanks for for letting us know @jcharette, we appreciate it!