Jamf Connect is grayed out for many users


We have been having this issue for months and have opened multiple support tickets. Just wanted to see if anyone from the community has resolved this issue.

Screenshot 2023-09-25 at 11.38.22 AM.png

Things we have tried:

- upgrading to version 2.27.0

- re-pushing the License configuration profile

- adding the updated launchagent to our PreStage

It seems this issue is caused by an invalid license, according to the Jamf Documentation: https://learn.jamf.com/bundle/jamf-connect-documentation-current/page/Installation_and_Licensing.htm...

"If a license expires or if Jamf Connect detects that an invalid license key has been applied to the configuration, the following functionality will cease: The Sign In window, accessed from the menu bar app under Connect..., will no longer function. Username and Password fields will be grayed out and users will not be able to click the Sign In button."

And for the deployment method for the License, there is one of two ways to deploy it. The one we use is Copy and paste encoded license string into a configuration profile.


Honored Contributor II

Deploying a new license file should fix any licensing issues. Though reinstalling the JAMF Connect client would not be a bad idea for persistant issues.


Another thought I have, its not mentioned where JAMF Connect validates its license though I am going to wager its from jamf.com and not the JAMF Pro Server. Have you verified all the correct network traffic is allowed?

Hi - We have tried reinstalling Jamf Connect, as well as deploying a new license file. I believe Jamf Connect was working completely fine, prior to the upgrade to 2.27.0, so all Network Traffic should be the same.