JAMF enrolled laptop showing unenrolled in JAMF Pro

New Contributor II

Several laptops, including my own, were enrolled in jamf and working fine. But now, when i go to jamf pro, it shows as if the laptops are not assigned to anyone. Because of this, I can't add the device to any new policies. The first screen is the view in JAMF Pro. On the physical laptop, all the current policies are still installed in Profiles.

But when i run 'sudo jamf policy' it says No policies were found for the recurring check in trigger.

When i run 'sudo jamf manage', it checks and updates daemon settings, but nothing happens.

When i run 'sudo profiles renew -type enrollment', it goes through the process of updating the configuration, but when it opens the profiles menu and I select allow, nothing happens.

I have also tried removing the laptop from jamf mdm and adding it back via Apple Business Manager. Then trying to enroll, but that did not resolve it either.

I created a case with JAMF and tried support chat, but they haven't been helpful at all. Has anyone else experienced issues like this?