Jamf Nation - Updates to My Assets

msonntag
Contributor
Contributor

Hello Jamf Nation!
We are happy to announce some changes to the My Assets experience that we’ve just released. The goal of these changes was to highlight the important parts of My Assets and, in general, make everything a little easier to find. I’ve summarized the changes below, but feel free to head over to My Assets, have a look for yourself and enjoy!

• Added a left-hand navigation to quickly jump to different asset types.
• Made Important Notices collapsible.
• Made SHA256 Checksum collapsible.
• New Download interface - If there are multiple OS types for an asset, the OS can be selected by a radio button.
• Added area for Primary Instance (disabled if you have multiple Production Instances).
• Made Instance table collapsible (Expanded by default if you have more than one Production Instance).
• Activation keys can now be copied in a single click by selecting copy to clipboard icon.
• (Jamf Pro and Jamf Connect) Previous Versions now has its own page. Link added next to “View Known Issues”.
• (Jamf Pro and Jamf Connect) Previous Versions and Releases can be selected via dropdown navigation.
• Removed “My Account Team” from page. Can be accessed from User Profile Dropdown (left-most icon on the Navigation Bar).
• Removed “Beta Programs” from page. Can be accessed from User Profile Dropdown (left-most icon on the Navigation Bar). • fixed issues occasionally encountered with asset types such as trials, development instances, etc. Those will now appear consistently for accounts with appropriate access.

13 REPLIES 13

sdagley
Honored Contributor III

@msonntag I have "Production" and "Customer Test and Development" instances, but only the latter is displayed, and there's nothing to expand for that section. Anybody else seeing that?

mm2270
Legendary Contributor III

For me, it seems like the changes broke things. I previously had access to an NFR license key, all current and previous downloads among other things under My Assets. Now when I go there I only get a message saying:

We were unable to find any assets for your account. Please reach out to support if this is a mistake.

I think that's a mistake, unless something changed that I wasn't made aware of. I'll reach out to support to see what they say about it.

msonntag
Contributor
Contributor

@sdagley Thanks for letting us know, we're looking into it right now.

Asnyder
Contributor III

Right now when hovering over the button to copy the activation code to the clipboard the cursor doesn't change, so it's kind of confusing to know if you can click there or not. You could just add a class like other items.

<span class="green-highlight cursor-pointer"><i class="jcon-copy-plain-text"></i></span>

apizz
Valued Contributor

I too do not have our production instance listed. Only Customer Test and Development instance is showing

msonntag
Contributor
Contributor

We identified the issue and were able to deploy the fix to production. The issue was specifically with test sandboxes displaying for certain perpetual customers.

@aporlebeke and @sdagley if you get the opportunity would you be able to confirm if the issue is resolved?

Thanks again for reporting it!

apizz
Valued Contributor

Confirmed resolved

sdagley
Honored Contributor III

@msonntag I can confirm I see both activation codes now. Thanks!

bradtchapman
Valued Contributor II

Previous versions is missing for JIM (the LDAP proxy).

sebFischer_
New Contributor

Hi @msonntag, i only see now our production instance. The test instance is missing! Can you have a look? Thank you..

DBrowning
Valued Contributor II

I'm not seeing our Dev instance either. Same as @sebFischer_

cdenesha
Valued Contributor II

The icon to copy the activation code to the clipboard is very small faint and thin, and I wouldn't know what it does without a tool-tip, or maybe zooming in to see it looks like a clipboard.

msonntag
Contributor
Contributor

@bradtchapman - Historically we haven't displayed previous versions of JIM, but it is something we can explore.

@sebFischer_ and @ddcdennisb We did take a look at your accounts and the data connection is there. I would recommend contacting support as it's possible they are expired or mis-configured on the Jamf side. They would be able to help square you away.

@cdenesha Thanks for the feedback! We'll look into making the clipboard icon more prominent/visible.