Jamf Pro 11 broke package uploads for certain users ("Upload fail: undefined")

Valued Contributor

After our cloud instance was updated to version 11 this past week, our team that uploads app packages gets an "Upload fail: undefined" error. It turns out there was an update to permissions that I can't seem to find any documentation on, so I figured I'd put it here in case anyone else runs in to this. If you have accounts that don't have full admin rights and need to upload packages, they also need CREATE on the "Jamf Content Distribution Server Files" permission.


New Contributor

I appreciate this post.  At my organization, we apply granular permissions for all Site Admins, and their ability to upload PKGs was broken after the version 11 update.  Adding this permission to the affected group resolved the issue for us.  It seems this new permission is connected to the new Jamf Cloud Distribution Point (JCDS 2.0.0).

Contributor III

same here and using Jamf Admin app to upload for now

New Contributor III

Can you show me the existing permissions of the package distribution team? (Before modification)


New Contributor

I'm actually getting the same error after moving to version 11 even with full admins, as well as another user who isn't but has been given that permissions specifically.  Anyone else having problems even with that perm?  Not sure what else to check/try.

Contributor II

I have this problem too, and am (in theory) a full admin on the site that I manage. 

I will be forwarding this article on to my fellow admins to see if we can find a solution.

New Contributor

Heard back from support on this - in our case, we didn't have the Cloud Services Connection set up (under Settings > General > Cloud Services Connection, you need to enter the creds for a jamf ID associated to your org).  Possibly we did before, I'm not sure (have just started working on this) but apparently with the migration to JCDS 2.0 even if you need have it hooked up before it may need to be re-validated.

New Contributor III

adding my jamf account under Cloud Services Connection also resolved my issue with the upload failed: undefined message that I was getting as I was trying to upload a package using the new version 11.x

Release Candidate Programs Tester

That worked for me! Thanks @PhillyPhoto for sharing!

New Contributor III

Weird issue... I also could not upload packages after the upgrade to version 11. My account was set to "Administrator" for privileges and not "Custom" we deployed Jamf years back.

But when I looked after this thread's recommendation, sure enough, it was "Custom" with the cloud distribution privileges unchecked. Set myself back to Administrator and packages uploads work now.


@PhillyPhoto  Thank you man!

Checked the CREATE permisson on "Jamf Content Distribution Server Files" fixed the upload failed issue.