Jamf Update to 1.29.0 fails (on premise, on windows virtual server 2019)

NOVELLUS
Contributor

Hello there,
hope, you're all well.
Today, I tried to update to Jamf version 10.29.0.
The update fails with a message "An error has occurred while extracting an archive".
(see screnshot). I tried various installations (for example a custom installation and a complete installation), I have downloaded the msi installer again, I extracted the ZIP file withe the build in zip service from windows, I extracted the msi with 7-zip.
In all cases, the installation failed with the message "An error has occurred while extracting an archive".
Is there anyone with the same issue ?
Maybe the hosted zip package will be corrupted ?
Thanks for your reply. Kind regards and have a nice weekend,

Michael
c66682a283044a11acb0b657f8a9ec18

3 REPLIES 3

ooshnoo
Valued Contributor

I suggest you contact Jamf support

luke_michelson
New Contributor III

@NOVELLUS I have experienced the msi failing when I click on it to install. However, if you open a command prompt as an administrator, then navigate to the directory where the msi is located and then run the command: msiexec.exe /i "Jamf Pro Installer.msi" I was able to get the installation to complete.

NOVELLUS
Contributor

@all:
sorry for my late response. Thank you all for your comments and hints.
Meanwhile I am informed, that the installer sometimes have issues, if it will be run under a virtual machine. We have a virtualized server to run Jamf Pro® and we have exact the described issues. I will try the next update by running the command in a command prompt.
Thank you again and stay health 🙂