JSS 9.98 issue

anitasmith
New Contributor

I updated to 9.98 a couple of days ago and now iPad apps that i have set to VPP install automatically are not automatically updating on the iPads. If you go into self service you can update them - so it is not an emergency. Just wondering if anyone else is having this issue.

12 REPLIES 12

Sandy
Valued Contributor II

https://www.jamf.com/jamf-nation/discussions/23559/after-installing-9-98-update-yesterday-apps-did-not-update-via-jss-overnight

murph
New Contributor III

@anitasmith Yep, we are having the same issue.

murph
New Contributor III

@anitasmith Are you seeing these errors in the logs at the time they are suppose to update?

2017-03-28 04:00:14,305 [ERROR] [ralPool-346] [licationCertificateHelper] - Error reading applicaiton certificates for mobile device ID ###

CasperSally
Valued Contributor II

Anyone running 9.98 not seeing this issue? Jamf told me this issue has been around awhile, but I'm on the prior hot fix without issue. I don't want to upgrade if it will definitely break and this isn't something easily tested in a dev env.

PI-003769 is the # Jamf gave me on this btw

murph
New Contributor III

@CasperSally We didn't have this issue until upgrading to v9.98. Things were working fine before that.

murph
New Contributor III

Anyone heard when they are planning on releasing their hotfix to fix this bug?

CGundersen
Contributor III

Fairly significant issue. JAMF has the staff, why not acknowledge/participate in threads such as this? With 9.98, we are also having to make accommodations (switch from HTTPS to SMB) for our 10.9.5 clients (EDU) to deploy policies. We missed the mark in our PreProd env. testing this release, but so much room for JAMF to improve their QA processes. I'm honestly not sure why 9.98 wasn't pulled.

Emmert
Valued Contributor

Our cloud instance is version 9.98.1491253513 so I bet something's already in the pipeline.

michael_devins
Contributor II

Hosted customers should not be affected by this automatic app update product issue. Any customer running Jamf Pro 9.98 on prem that is experiencing issues with automatic app updates should contact your Jamf Buddy to inquire about a fix. Thank you for the discussion!

murph
New Contributor III

@michael.devins I opened a case regarding this on March 28, the day after I installed 9.98 when I noticed the next morning that apps did not update. All I keep hearing is "soon".

CGundersen
Contributor III

Our JAMF bud is great ... no hotfix available to us (on prem) yet though.

michael_devins
Contributor II

Hey @smurphyusd346 & @CGundersen, I might have been a couple hours premature on my advice. It sounds like information has just recently been posted to Support for resolving automatic app update issues. Sorry for the false start, but information should now (or very soon) be available with regard to automatic app updates for on prem instances.