JSS Upgrade Failed

New Contributor

I tried to upgrade the JSS from 9.65 to 9.73 on Windows Server 2008 R2.

It failed and said "changes rolled back" but Tomcat would not restart. I then tried to go back and reinstall 9.65 and that failed as well. I tried 9.73 again....well you get the idea.

At the first attempt, the final lines of the log file show:
Expanding ROOT.war by jar command...
"%JAVA_HOME%injar" -xvf "C:Program FilesJSSTomcatwebappsROOT.war"

At the attempt to reinstall 9.65 the final lines show:
Checking if Logs directory exists...
Error changing log paths:

Next attempts at installing 9.73 all show the same error:
Checking if Logs directory exists...
Error changing log paths:

Everything else in the log files looks fine. I am a little surprised that I got different errors the first time I tried 9.73. The dialog error window that popped up was different the first time than all the other attempts (and I can only recall it saying something like "failed to start tomcat service" or something.

Anyone see anything obvious -- please....
Thanks for any help.


Legendary Contributor III

See this thread - https://jamfnation.jamfsoftware.com/discussion.html?id=15175
There have been reports of failed upgrades to the new 9.73 version. @amanda.wulff from JAMF chimed in on the thread with some additional instructions on doing a manual upgrade, but not sure if this will help you in your case, or if you'll just need to open a case with your JAMF TAM.

Valued Contributor II


I would recommend checking out the thread that @mm2270 mentioned, as some of the steps may be helpful for future upgrades.

It's also worth noting that we did have a new defect open up today in which the 9.73 installer is sometimes removing the JAVA_HOME variable when it is not supposed to; when we hit that, we see the error at the end of the log that you mentioned in your post.
That defect is filed under D-009350, for reference.

In this particular case, I'd recommend you get in touch with your Technical Account Manager so they can assist you in getting things back up and running.

You can do that by giving Support a call, sending an e-mail to support@jamfsoftware.com, or by using the My Support section of JAMF Nation.

Amanda Wulff
JAMF Software Support

Honored Contributor

@amanda.wulff - FYI, that same thing happened today upgrading on Win 2008 R2. "JAVA_HOME" variable was missing. Once we re-created it things were fine. Just letting you know that this is not just in 9.73.
We went from 9.65 to 9.72 (9.73 too new to risk).


New Contributor

OK, I've verified that the JAVA_HOME and JRE_HOME and JSS_HOME exist and are appropriately defined. The install failed again with the same error in the log (as mentioned in my original post).

When I try to attach to the JSS I get a 404 with description:
"The requested resource is not available."

The logs showed everthing else successful, including unpacking the ROOT.war file.

I looked at the ROOT folder in pathtoTomcatwebapps and the folder exists but it is empty. Unfortunately I don't have a copy from a working installation.

I have a feeling I really need that Database.xml file... help?

New Contributor

I did find a backup of my old ROOT folder in the JSSBackups folder. I will try to restore my 9.65 installation.

In the meantime, another bit of information. The installation seems to successfully start the tomcat service. However, when I manually stop it, then try to restart it, it fails with:

System error 2 has occurred.

The system cannot find the file specified.

New Contributor

Update: After copying over my backup ROOT folder, and reinstalling 9.65 I am back up and running. I will attempt a manual upgrade to 9.73 once I'm officially back at work this week (not on Sunday).

Would be nice if Jamf got this fixed before then though....

Thanks everyone for the help!

Valued Contributor

@amanda.wulff FYI
JAVA_HOME variable was missing even before 9.73 upgrade.
We are on JSS 9.63 and no JAVA_HOME variable in Server 2008 R2.