M1 Macs restarts/shutdown after remote enrollment/setup


Hello everyone,
We have encountered a problem that we have never encountered before. When we enrolling our new M1 Macs, the computer restarts or shuts down after we have logged in at the remote management.
The only thing left to do is to reinstall the computer again. If we're lucky, the problem won't reoccur. But we have had to reinstall some computers several times.
The devices ship with macOS 12.3.0 and we're running on-prem Jamf Pro 10.30.3, if that makes any difference.

What could be the error? Does anyone know? Is there any solution? Seen others with the same problem on this forum but not with any confirmed solution.


Out of 60 brand new machines out of the box, never used before we've encountered this problem with rubout 7 out of 12 machines. After reinstalling them they usually works great. 1 or 2 machines we had to reinstall 2-3 times before they passed though the whole process. We don't get any kernel panic message that you usually do.



is there any reason you are still using 10.30.3? This version of Jamf was never officially tested with Monterey, at least as far as i know.
Did you tried to check the Shutdown logs with:

log show --predicate 'eventMessage contains "Previous shutdown cause"' --last 24h

 alternatively using:

log show --predicate 'eventMessage contains "System shutdown initiated"' --last 24h

could give you some other information about the reason why a shutdown was initiated.
just change the time after --last to whatever suits your case.


Thaks for the information. In this case we can't login om the Mac after shutdown we only reach the login window, can't create any new user account and the admin account is there but the set password doesn't work.

Can I use the log commands above in recovery mode to get the information?

The reason why we're still on 10.30.3 is that we've been having problems upgrading and haven't hade enough time to dig in to it to solve the problem.


The log command is using the logdaemon so if they did not changed the behaviour on m1 systems it should not be possible in recovery mode. If someone has a way to do it i would be interested in it myself.

Pushing a new Account trough a Jamf-Policy (at least on one afflicted Device for diagnostic reasons) using the Local Accounts payload could be an option. Even if a Computer is in the login windows it will still do the recurring Check-In. Which will turn the potential Login into a waiting Game... but i assume you already tried creating the account trough a policy.

New Contributor II

Running Jamf Pro 10.43.1.

I had this issue today affecting about 10 computers. Most were also brand new M1s out of the box. The issue did not affect any Intel Macs.

Called Jamf Support and they were able to help me figure out that the local admin account name in our Prestage account creation was exactly the same as the account created in our User-Initiated Enrollment settings.

Once I changed the account name in User-Initiated Enrollment, the issue went away.

Hope this helps!

New Contributor II

Thank you beegee for your fix/comment. We had around 60 M2 Pro Macs for a roll out having issue and were having a mini panic! Renaming the management account for UIE has resolved the issue. Thank you!