Mac app store apps asking for Apple ID

New Contributor III

We are on 9.82 and are using Device Based Assignment for all of our apps, but when I add mac app store apps (that we have licenses for) it will occasionally pop up asking for an apple ID.

It seems to be only on computers that have at some point logged in to an apple ID, and resetting the iTunes cache will sometimes work, and sometimes not. On the ones that it doesn't work for we have tried reenrolling, deleting self service and reenrolling, deleting self service and replacing it from the JSS without reenrolling, but nothing seems to work.

We have a support ticket that is ongoing - but the general response so far has been 'it must be an apple thing'.

Is anyone else having this issue, or have had it and have fixed it successfully?



New Contributor III

I had an issue similar to this with getting a High Sierra installer via volume licensing that had to do with the current version of the machine trying to get the installer - sounds like a different issue, but figured I would share just in case.