Mac App Store Install Automatically after Casper Image

New Contributor III

As a Higher Ed client we use Casper Imaging to deploy a set Install configuration to all computers. With the new Device based VPP Deployment we have begun the process of testing this process to replace process of packaging App Store applications.

So we have gotten 2 free apps added to our VPP code (Slack, xCode) and have setup the Mac App Store apps and have gotten them connected to the VPP assignment with setup to install automatically. After Casper imaging the Slack app installed automatically, but the xcode app has not. The computer's install.log doesn't show attempts to install xcode. Why is that? Is there a process we can trigger to force the App Store apps to install? xCode still shows as pending in JSS.


Valued Contributor

Interesting you bring this up @cvangorp as we too are just getting our VPP installs working. We have some our computers ready for the iWork apps such as Keynote and we also put out Xcode. However, in one case, the customer removed the existing versions of Keynote and the new VPP versions are not installing.

I wonder as well if there is a trigger mechanism involved. I have forced a recon update on the one client, but that hasn't done a thing for us. Anyone else out here doing VPP and can guide us a bit? I did notice over night that a number of our employee Macs received the VPP applications, but I don't know what made it happen.

Perhaps this is nothing more than patience?



Did anybody have suggestions for this issue? I am planning on integrating all of my labs over the summer to use JAMF for the first time. So far testing with a machine I'm not too happy on how the Device Based VPP apps get deployed. I have several apps (Keynote, Pages, Numbers, etc) and after the computer is imaged, the first time I login I see a message that says "Updating Managed Settings." Many of the Mac App Store applications that are on the dock appear as a question marks until the apps download. Is there a way to force the install in the background so the first person to login doesn't have to wait for the apps to download.

My fallback is to package the apps and deploy them using polices but I figure it would be more manageable going through VPP distribution.

Contributor III

There's bugs with device distribution VPP apps, on the JAMF side not the Apple side. From my testing I have the following notes.

When a VPP application is in scope the following situations ocassionally occur resulting in the VPP application to not be deployed to a client. Sometimes there will be pending commands for the device. If the only pending commands are the InstallApplication MDM commands (ex. Install App – Pages). If you log out and back in as an MDM capable user on the client computer the commands will execute successfully and the apps will be installed. Sometimes there will be where the App supposedly installed based on logs but does not exist on the client computer. Sometimes there will be no pending commands, no logged install actions, no logged MDM commands. App is not installed on the client computer This only occurs on clients that already have a computer record in the JSS. I have not been able to replicate these failures when the record is deleted from the JSS and then a VPP app deployment is scoped.

I worked with JAMF and apple for about a month and eventually gave up and are still packing apps, deploying them with policies. I need device distribution to be as reliable as doing a policy.

If the VPP app has a category assigned it will show up in Self Service. Clicking the SS button will always cajole the application to deploy. But then the install button is always in SS, even after it is installed.

New Contributor III

We were excited to implement this feature to our summer refresh of our lab machines but I am testing right now with Apple Logic X and am running into issues.

They're making progress from when we 1st played around with it, but here we are finding issues with it. I won't rule out we might have certain settings or tweaks that need to be made on our end, but hearing other remarks sounds like it still has room for improvement.

Just recently we tried deploying an app this way and it was stuck doing nothing and read on another thread post that it wouldn't work if you scope it to one computer but needed to be in a group, which seemed to have worked, but we are seeing issues now with trying to push Logic to a iMac in a group, so unless we are doing something wrong, looks like still needs some work.

And to step back, we were told recently that in order for apps to be pushed, an MDM user needed to be logged in, which would be nice for a lab setting we could get around that some how so we don't have to touch each machine 1st or a first time login user needs to wait for an app to be installed.

We are hoping the bugs will be sorted out because we do like the philosophy of how the process should work, because on the backend it is nice to monitor licensing and reclaim and redistribute etc.

New Contributor III
that in order for apps to be pushed, an MDM user needed to be logged in

This - I was trying to implement the exact same workflow with the iWorks suite and the apps would come down from the Mac App Store without a problem so long as the original local user was still logged in - unfortunately my workflow involves removing this account, leaving no local accounts as MDM enabled... This scares me with the upcoming macOS version killing off monolithic imaging, we have far too many reasons for baked in apps in our environment!

Contributor III

Has any of this been resolved since the last post by @cboatwright ? We're experiencing the same issue and then some. One thing that also happens is that a popup authentication box appears. Something with the naming of Downloadstore, looking for admin name and password to proceed. Very strange. At this point all I can do is put them in Self Service to be installed when needed. Not a very good solution.

We are still running Casper 9.98 and I was thinking about upgrading to 9.100 to solve the scripting issue that is in 9.98. Did 9.100 resolve this issue?

Thank you everyone for the great posts on this topic.

Contributor II


we are experiencing the same issue with some apps. We need to get those computers out of the scope and put them back in and it works

also, computers in scope sometimes won't work... need to put them in groups