Mac Apps (Xcode) specifically not updating

New Contributor II

I have several users who are not receiving newest Xcode update via Mac Apps.  In self-service, it shows 14.3.1 but no install button, but an open button.  When the user opens Xcode, it's 14.1 and have tried to force updates to no avail. 

I am trying the unscope and re-scape method now, but its there any reason that the Mac App Store would do this?


Contributor II

Do you have it set on each mac app that they poll for updates and force them out?


I've screencapped what the settings look like but you need to enable 'schedule updates' and 'automatically force updates'

Screenshot 2023-08-31 at 14.31.22.png

New Contributor II

That's what mine looks like except, my category only shows "none".  I deleted my Xcode distro and created another one.  maybe it was corrupted???

You need a category assigned (definitely on the self service page) or it doesnt display in Self Service!

Its ticking boxes but confirm the following:

  • The scope is set correctly
  • The managed app tab has licences assigned from VPP and is enabled

The managed distribution tab:

Screenshot 2023-09-01 at 12.21.39.png

The overview on the Mac Apps pageScreenshot 2023-09-01 at 12.21.08.png

New Contributor II

Screenshot 2023-09-01 at 8.44.57 AM.png

 The overview on the Mac Apps Page.

Screenshot 2023-09-01 at 8.44.03 AM.png

 Self-service page.

Screenshot 2023-09-01 at 8.44.14 AM.png

 Manage distor page

Screenshot 2023-09-01 at 8.47.17 AM.png


Screenshot 2023-09-01 at 8.43.38 AM.png

 Self-service app does not show install button for 14.3.1

Screenshot 2023-09-01 at 8.46.09 AM.png

 History says it installed 14.3.1, but Xcode is 14.3.0.

This is my case.  I have other users who do have 14.3.1 and some that have older than 14.3.1, including myself.  Looks like Self-service app may think 14.3.1 is install but it isn't.



Have you tried clicking teh 'force update' button on the first page of the Xcode macapps page, just below the schedule updates section?

New Contributor II

I have tried that a couple of times.  I also opened a case with Jamf Support and this is what I got:

Regarding seeing "Open" this would be expected in Self Service. As long as the application is installed it will show "Open" even if the application has not yet received its application update.

On a device seeing the issue if you run Sudo Jamf recon in terminal and wait 10 minutes do you still see the old version installed? If not if you up the device in Jamf Pro do you see a command for the app installation listed?

- I ran Sudo Jamf Recon on my Mac and waited the 10 minutes.  I opened Xcode and the version showing is the same and is reporting correctly in Jamf Pro.

Screenshot 2023-09-01 at 9.31.32 AM.png

 This is my Mac and it shows Xcode failed command and I don't know why those other commands are still pending.

New Contributor II

Screenshot 2023-08-31 at 9.40.08 AM.pngScreenshot 2023-08-31 at 9.40.21 AM.png

Valued Contributor II

Are you using VPP and have enough licenses assigned? 

I ran into this a while back. One specific computer wouldn't update. It turns out he was low on HD space. Xcode is a big app.


I think I fixed this for someone else by deleting the Xcode from the endpoint. He had downloaded it with his Apple ID. Then we installed via Self Service, VPP Managed app.

New Contributor II

Yes, we have 100 licenses and are using 10 thus far.  This particular user has 300+ GB free and I hope hasn't installed from App Store. We restrict that, too.  

I have tried automated updates and Self-Service as well.  The self-service app shows 14.3.1 and says "open" but the actually app is 14.1 ... so, not sure what it's doing.

Valued Contributor II

Did you try deleting Xcode on one of the clients and then re-installing via Self Service/VPP/Managed app?

Try removing it with app cleaner and then re-install.

New Contributor II

I am doing that now, but it won't install.  I think the bigger issue is that none of my management commands are doing anything, just pending.  Occassionally, one will fail.  Maybe it's not how I have the app setup to update (because it worked in the past...) but because I am having issues communication with the MDM? 

Screenshot 2023-09-01 at 11.18.31 AM.png

 I have cancelled the Xcode a couple of times, but it sat for 40 minutes and literally did nothing but spin.  It is not a network issue because I have been off and on my VPN and nothing changes.  There has to be a communication issue with Jamf???

New Contributor II

not connecting to Jamf serversnot connecting to Jamf servers