MacBook Air NetBooting

New Contributor III

I'v been trying for 2 weeks to get any MacBook Airs Netbooting on the network here but cant get anywhere.

I created my netboot environment image from the latest macbook air, uploaded it into the server and everything can boot to it except for macbook airs. My iMacs and White MacBooks boot perfectly into it.

When using USB ethernet it just boots off the default internal hard disk, Even if i manually bless the computer using

bless --netboot --server bsdp://serveraddress

Are there any tricks i am missing to make these Airs netboot? The computers act like they have not even tried to netboot.

They are in a different subnet, thats why i am not using the N key to auto netboot, but manually blessing them.

I have followed the JAMF guides on making a base netboot image, and as i said, everything works except for MacBook air netbooting.

Any assistance would be greatly appreciated.


Esteemed Contributor III

What OS is your NBI?


Honored Contributor II
Honored Contributor II

You said you created the image from the MBA, but did you do all of it on the MBA? Meaning, did you capture the image using Composer on the MBA and did you run System Image Utility while booted on the MBA?

New Contributor III

We are about to deploy about 800 MacBook Airs and decided to do it using target disk mode over thunderbolt. What we do is take a few spare MacBook Airs and put Casper Imaging on them. That way we go from one MacBook Air to another. So... SSD --- Thunderbolt --- SSD. We can image about a 15GB image in 2 minutes. We havent gone the NetBoot route because it is much slower.

New Contributor

I've had the same issues trying to get the MBA'11 to netboot. I plan to "Thin Image"a couple hundred, but currently I'm unable to get then to Net Boot. I tried the automator script, but the MBAs will never boot, grey screen and/or just reboot loops when I try. I made the Image using a 10.7.4 MBA and a 10.7.3 (Mac Book white). Other machines will boot from the image fine.

Anyone have any luck Netbooting MBAs?


Valued Contributor II

I netboot macbook airs over the ethernet adapter. mine are new airs though, if that makes a difference.

My netboot image is based on a 2 year old unibody macbook. I did run combo update to get it to 10.7.3 I think it is.


i'm with sally: no problems on our end and we are using the usb/ethernet adapters and a 10.7.3 image we've been using for some time now. at this point we're able to image mb airs, mb pros, mac pros, etc.

looking forward to updating to v8.5.x so that we can start to test target disk mode imaging for the airs. we bought a $4 million cable from apple to provide us the luxury of doing that.


New Contributor

don't know if this will help at all.. but -

I have had the same trouble recently with a MBA3,1 - what i was finding that if i just plugged in the USB Ethernet adapter and attempted to NewBoot, it wouldn't.

that was already a blank machine with no OS.

I used an apple provided USB installer to install an OS, then logged in and plugged in the adapter, when i could see there was connection, use restarted to NetBoot via the startup disk options in system prefs.

took a little while to start up... however, it is imaging as i type, then NetBoot image did load.

New Contributor III

I know this is an old post but we are having the same issues. when trying to boot to netboot on restart using the same command you are showing.

I have tried every combination i know of and even talked to apple engineers about it. (they are currently helping with it but no solution yet)

It seems to be directly related to the network interface since it works perfectly fine on machines that have built in ethernet but won't work on macbook airs with the thunderbolt to ethernet adapter. I have even specified that network interface in the command below and it just boots directly to the standard OS even though the command issued is accepted and shows that it set the efi in the logs.

bless --netboot --verbose --nextonly --server bsdp://

New Contributor

@jreeves Did you ever find a solution for this? I ask because I've just received a set of MacBook Pro Retina 13" laptops and can't get them to netboot over thunderbolt ethernet.

I've built a light image of Mac OS 10.9.3 as well as installed deploystudio to create a netboot set from these laptops, and the images don't load.

If I hold down option to select my image, I'll get the blinking large globe but it never gets past that and reverts to the local disk. I've confirmed the same problem with other laptops using thunderbolt ethernet (11" Air and 15" Retina) but anything with built-in ethernet works fine, as you noted.