Macbook Pro 2018 model, can it run macOS 10.13.3?

Contributor III

Hi all,

Do excuse me for being lazy, wondering if anyone within this Mac community have the same issue.

Now that Macbook Pro 2018 models are out, our company have been purchasing them. Our company is full of docking stations running displaylink to external monitors. As such, we have been rolling out Macbooks with 10.13.3 only, as any later OS will stop displaylink from working.

Back to main topic, I tried to install/boot up the Macbook Pro 2018 with a macOS 10.13.3, it starts up with an error message "A software update is required to use this startup disk"

So can anyone confirm that Macbook Pro 2018 model requires macOS 10.13.6 ?

Thanks in advance.


Valued Contributor


Hey Bernard... another article worth mentioning is from Jamf's own blog:

View solution in original post


Valued Contributor

I would say it does.

New Contributor

How are you installing 10.13.3 on this machine?

This message is most likely being generated by the T2 chip in this machine. There is a chance you will need to downgrade the security settings to install an older version of macOS. Take a look at this article on Apple's support page for more information about Secure Boot on new Macs:

We just got a few new iMac Pros so I am just learning about the ins and outs of deploying macOS with the T2 chip and Secure Boot.


It theoretically should be able to, but how would you plan to install 10.13.3? I guess you could disable secure boot and load a flash drive with 10.13.3 and wipe/install the drive that way, but I could see firmware being an issue (which is maybe why you got the message), especially for things like the supplemental fix for 10.13.6 that addresses the overheating issues. Either way seems like a bad idea to go backwards.

Esteemed Contributor II

Short answer - you can't run anything less than the version of macOS that came with the 2018 MBPs. You've got a new generation Intel processor, the new Intel support chip(s) for that new generation processor, and Apple's T2 chip in the 2018 MBP. macOS 10.13.3 is not going to have the required drivers to support all (or any) of those changes.

Contributor III

Hi all
just received a 15" 2018 MBP, it comes with a custom build of 10.13.6 (17G2112, that's before installing the MBP 2018 additional update Apple has just released and I have not applied yet, although it shows up in AppStore updates)
After disabling SecureBoot:
It does not boot with an external USB "ordinary" 10.13.6 (17G65), so it defenatly takes its very last High Sierra custom build Netboot does not work, disks do not show up in System Prefs nor with option key at startup
The Netboot image I created (17G2112) can successfully boot previous 2017 models (and from there backwords, such as a 2012 MBP I have tried with) (so netboot it's blocked client side on 2018 MBPs)
USB boot does work as expected with the right OS build...

Valued Contributor


Contributor II

10.13.3 won't work on a 2018 MacBook Pro by the design of how macOS updates are released and builds. I know imaging is dead, but I'm pretty sure I've seen this in the documentation for mac OS Server docs for building images. If a new model comes out during a current release of macOS, it will have a separate build of that release compared to what was previously distributed via software update. IE, if you have a copy of 10.13.6 that was created before the version that shipped with the 2018 MacBook Pro, it is possible that the copy you have won't be compatible on a brand new machine. Once the next version of the OS comes out, the drivers for all current and compatible models will be included.

Valued Contributor

Apple stated that any Macs with the T2 chips no longer support netbooting, so that means the latest iMac and the 2018 MBPs.

Contributor III

Thanks everyone.

I'm getting the consensus that it can only run 10.13.6, and I can't do netboot / reformat via USB.
Overnight I did more investigation. Within the recovery partition, there is a selection to change startup Security Utility, so now it can boot up from an external USB drive. d89e8caa13304ddabe5282d1e94fd359

But still, it wont boot up with a OS less than 10.13.6. This is going to be a big problem for me.
Our company has a policy to wipe out all data when the Macbook is refreshed or change user. Security is more important than keeping data.
So the ASR restore was working great for us.

We use the command
asr restore -source /dev/disk## -target /dev/disk## -erase
to do our disk reimaging.

This worked great for 10.13.3. But when doing this for 10.13.6, I get the following error:
"inverting target volume APFS. Inverter failed to invert the volume - invalid argument"

Valued Contributor

Bernard... A Mac only being able to run the specific OS that it comes with is nothing new. This has been the case w/Apple hardware for years.

And since you can't netboot the 2018 MBPs, I suggest you create a self service policy that downloads the latest OS installer, wipes the drive and reinstalls the OS utilizing the "startosinstall" command.

See this page for more info:

Valued Contributor

I hate to pile on but like ooshnoo said this is nothing new. Even back in OS 8 and OS 9 days this is how it was with new hardware. You got lucky if it ran older (see current MacBook Air) but 9/10 times it doesn’t.

On top of that the iMac Pro should have gave you a hint that it wouldn’t NetBoot since it has the T2 chip.

Further more Apple has been pushing people from moving away from netbooting.

I know how some companies and organizations can be in terms of policies and such but if you invest a few thousand dollars per machine, you should know what you’re purchasing.

Contributor III

Thanks guys.
It's not the moving forward to latest macOS I'm concern about (although it certainly sound like I do).
But it's the effort of restoring the OS to a fresh build that troubles me.

If/When ASR was working, it takes me 10 minutes to recover a Macbook, and it's ready to be used by a person.
Now that ASR no longer works, it will be 40 minutes or more to install macOS. And people being people, they are not waiting for me that long to get them working again.


New Contributor III

Using the --eraseinstall tag you should be able to erase an APFS drive faster than 10 minutes.
Haven't taken a closer look but here's some possible inspiration as also mentioned by @ooshnoo

Valued Contributor


Hey Bernard... another article worth mentioning is from Jamf's own blog:

Contributor III

Thanks @ooshnoo :) Voting your answer to be the solution.

Obviously a few rounds of testing before we declare this is the way to go.
And I don't think I can make this available to everyone within Self Service. Our users NEVER read the description of any of the installs. They will just click on it, then blame our support team for wiping their hard drive. We'll scope it only as requested.
I can already foreseeing working great with DEP.

Once again, thanks everyone for your comments :)

Valued Contributor

If you enable logins for self service you could scope to just an ldap group with your tech. Scope to all computers and limit it to those users.

Esteemed Contributor III


@talkingmoose's blog is spot on. Awesome stuff. Works with 10.13.4 and that new macOS <redacted>.


New Contributor II

@Bernard.Huang hey, we are in the exact same position as you with display link and the new Macs. did you manage to find a good work around or a temporary solution?