MacOS 10.13.4 Wont update until showing in AppStore

New Contributor

I am running into an issue when trying to do a no touch install the 10.13.4 using Jamf. I have downloaded the Combo update as well as the standard update directly from Apple. I have tested with both of these .dmg files, as well unpacking into the .pkg files.

I have tested direct install via policy, cached file via policy then install via policy with smart group, install via patch management, install via Jamf Remote, cache via Jamf Remote then install cached via Jamf Remote.

Some of these show the install completed, while others gave an error about the drive not being active.

After reboot, each of these methods had FAILED, and the mac had not updated to 10.13.4.

I checked the AppStore for updates on the machines that failed the install, and on those machines, it shows NO updates available (even though the test machines have been on 10.13.2 and 10.13.3).

I found if I leave the machine on, and connected to the internet, they will eventually (usually a day or so after I leave them connected) show that there are updates available and prompt to install.

At that time, I can use Jamf Remote to run the command "softwareupdate -i -a", and it will install successfully. (I know this downloads directly from apple, and doesn't use the .pkg or .dmg files that I had put into Jamf) This is the ONLY way I have been able to get this to no touch install to each of my devices.

Is there some sort of flag on Apple's side that is preventing these devices from running the install if the update isn't showing within the App Store? I want to no touch deploy this update so that the user does not need to do anything, just leave the mac on, and the install will happen without them needing to push a button (since it's hard to get users to comply).

Any assistance would be appreciated.


New Contributor III
others gave an error about the drive not being active

Well… that's a little bit weird.

it shows NO updates available

Do you have any Software Update Server running locally, or set up ?

New Contributor

No, we do not have a software update server running locally. I was just hoping to be able to tell my users to leave their mac's turned on, and then push the update without the user having to do anything.

New Contributor


Here is a screenshot of the log file. The macbook is on 10.13.2, trying to push install of 10.13.4 with no interaction from the user.

New Contributor

Here is another machine running 10.13.3, trying to install 10.13.4 pkg.


New Contributor

And here is the log after successfully running the command: softwareupdate -i - a through Jamf Remote. This was ran after this computer had been sitting logged in half the day, and had not shown updates available until just before I had ran this script. f35a41a4c2b54c0383a32fec5bea3b85

The system rebooted and installed the update successfully.

Contributor II

I am having the same error "The volume does not meet the requirements" on both a MacBook Pro running 10.13.4 and a iMacPro running 10.13.3 . I get the error when trying to run the 10.13.4 or 10.13.5 combo updates from apple. I have also tried changing my SUS back to apple and it shows no updates avalible.


Contributor III

I think we've been seeing something similar but in our case it seems to be because the drive is still encrypting. As soon as the drive is done encrypting updates then become available. It could be coincidental, but just tossing that out there.


Contributor II

The laptop is still encrypting @ 43 % right now. But my iMacPro is 100% encrypted. Im going to try that system again with both the 10.13.5 combo update and update.

Valued Contributor II

I am seeing similar behavior here. I ran both the delta and the combo manualy/locally on a couple IT test iMacs and went home for the night. The Macs appeard to install & reboot, but the next moring I realized the updates did not occur.

I just pushed the 10.13.5 combo updates to a couple other IT iMacs via ARD and went to lunch. Came back with tacos in my tummy and discovered the same thing occured again.

-All Macs were late 2012 or newer.
-Macs were running 10.13.3
-No FileVault or EFI restrictions.

Haven't had time to dig into it yet. Will investigate logs, etc later today.

Contributor III

I was successful in updating my main iMac to 10.13.5
It took about 40 minutes with 4 reboots. Luckily I have a laptop to work on while this was taking place

Contributor II

My only option was to do a in-place install of 10.13.6 full OS. Via recovery mode nothing could get that update installed.