Macs Freezing When Left On Overnight

JLNewsome2
New Contributor

Hi guys... Hoping someone can shed some light on this for me.

I am experiencing an issues where a mixture of hardware in the shop I work in has an issue with freezing up when left at the login screen overnight. I've done some reading about this on other forums but haven't found a definitive answer. I have tried an SMC reset, I don't have VMWare Fusion on any of the machines (possible culprits I have seen on other forums) and it's a mix of Minis, iMacs and MBPs - all on 10.11.6.

The users are complaining because they have to reboot their machines every morning when they come in. I instruct them to leave their machines at the login screen overnight - and the next morning they come in, try to move the mouse or type on the keyboard, and get the rainbow wheel of death until they do a hard reboot.

It's rather annoying. Has anyone else experienced this? Any solutions?

6 REPLIES 6

thoule
Valued Contributor II

Not knowing how those machines are setup it could be so many things; too many to start making guesses. Take a look at the system log (Utilities -> Console) and see what it says when things hung. Also look for crashlogs in /Library/Logs/DisgnoticReports. Not likely to have one if you see the pinwheel, but maybe worth looking...

stevewood
Honored Contributor II

@JLNewsome2 Do you have any configuration profiles set that are managing login window or screen saver idle time or anything like that? We had similar issues, although it was when machines would come out of sleep, and we tracked it down to the bug in applying multiple Security pref pane items in one configuration profile.

There's a bunch of info in this post: Require Password after sleep or screen saver begins. and then you can go read Kitzy's blog post about how he fixed it: Security & Privacy Configuration Profile bug in Casper 9.82 and finally @bentoms solution: ICLOUD, SPOTLIGHT & LOGIN WINDOW ISSUES WITH JSS 9.9+ & THE SECURITY & PRIVACY PROFILE PAYLOAD

Not sure any of that will help, but once I followed the instructions @kitzy had on his blog, my problems went away.

jordanfleuriet
New Contributor

hey @JLNewsome2 - my org is seeing this as well after after our cloud JSS got upgraded to 9.93. Are you on 9.93?

jordanfleuriet
New Contributor

We have been testing the all in one solution payload solution by @bentoms . We aren't having much success with the afflicted machines. We are seeing the odd sleep/hibernate behavior across 10-20% of our machines...the rest seem to have upgraded to 9.93 with no issues. Paired with these issues we also are seeing Thunderbolt/USB issues where ports stop working randomly which impacts USB devices and Thunderbolt displays.

Anyone else seeing this?

bentoms
Honored Contributor III
Honored Contributor III

@jordanfleuriet It's not something I've seen.. But are you imaging them? If so, how was the base OS created?

makander
Contributor

I'm also having this issue as well and afaik it started after 9.93+.

What I've tried so far is:

  • remove and re-create the configuration profiles.
  • separate settings into more profiles.
  • combine profiles that manage the same preferences.

Still freezes up after sleep and requires a reboot.